2006 k1200s Elecronic problems - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old May 7th, 2017, 6:33 pm Thread Starter
Noob
 
Join Date: Sep 2016
Location: fletcher, nc, usa
Posts: 8
2006 k1200s Elecronic problems

I bought a used 2006 k1200s specifically because everyone seemed to love that year. Amazing bike for a while.

About a month ago the brake warning light came on. Checked the book says low fluid or pads. checked both theyre fine. Breaks work great. You can hear the servos whine and feel them operate. About the same time i got LAMPF.. i THINK the tiny center bulb is out. Havent had time to change it and cant really tell if its blown

In the last week or so: the clutch slave cylinder went out. .waiting on a SLOW canadian to ship mine. Last night i turned on the bike and headlight didnt come on. I flipped on the high beam and the high beam worked. After about 10 minutes of riding im guessing low beam started working and works fine now. About the same time (this weekend) the fuel guage crapped out to always empty.

I know the clutch slave and fuel sensors are known problems and i only mentioned clutch slave a: to bitch b: in case some of these things are related. Im starting to think theres a short or a computer problem. Brakes are FINE. All these sensor warnings started happening near the same time like a cascade failure. Im replacing that bulb asap and the clutch slave asap but im not paying bmw $$$$$ to tell me i need 5000 in bullshit when its some arcane electronic glitch? ANY ideas??? I just cant believe the bike pretty much started falling apart 6 months after it left the dealership. Frankly at the moment i wish id bought a kawa 1000
cdreid is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old May 10th, 2017, 11:49 am
Noob
 
Patrique83's Avatar
 
Join Date: Apr 2017
Posts: 8
Garage
I would remove the left fairing and pull the plugs on the ZFE unit (which controls your lights, fuel strip etc.)


Not that you have corroded pins.
Have you been riding in the rain lately?
Further diagnostics can really only be done by the dealer.

The low beam lights being off when turning the key (not starting the engine) is a programable feature.

My bike somehow lost this after i let the battery go completely flat. I recoded it and everything was back to normal.
Patrique83 is online now  
post #3 of 4 (permalink) Old May 10th, 2017, 3:07 pm
Noob
 
Join Date: Jul 2014
Location: , ,
Posts: 3
Quote:
Originally Posted by cdreid View Post
I bought a used 2006 k1200s specifically because everyone seemed to love that year. Amazing bike for a while.

About a month ago the brake warning light came on. Checked the book says low fluid or pads. checked both theyre fine. Breaks work great. You can hear the servos whine and feel them operate. About the same time i got LAMPF.. i THINK the tiny center bulb is out. Havent had time to change it and cant really tell if its blown

In the last week or so: the clutch slave cylinder went out. .waiting on a SLOW canadian to ship mine. Last night i turned on the bike and headlight didnt come on. I flipped on the high beam and the high beam worked. After about 10 minutes of riding im guessing low beam started working and works fine now. About the same time (this weekend) the fuel guage crapped out to always empty.

I know the clutch slave and fuel sensors are known problems and i only mentioned clutch slave a: to bitch b: in case some of these things are related. Im starting to think theres a short or a computer problem. Brakes are FINE. All these sensor warnings started happening near the same time like a cascade failure. Im replacing that bulb asap and the clutch slave asap but im not paying bmw $$$$$ to tell me i need 5000 in bullshit when its some arcane electronic glitch? ANY ideas??? I just cant believe the bike pretty much started falling apart 6 months after it left the dealership. Frankly at the moment i wish id bought a kawa 1000
If you dont have a GS911 tool, it would be a good idea to think about investing in one. I bought the cheapest USB enthusiast ver while it was on sale and I love it. Tells you everything you need to know about the bike and what its doing. It will also tell you if its having or had any communication issues with any of the modules/controllers. This will give you a better idea if its the KOMBI controller or just more of a weird coincidence.

Dan
2wheels1love is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old May 11th, 2017, 7:00 pm Thread Starter
Noob
 
Join Date: Sep 2016
Location: fletcher, nc, usa
Posts: 8
Thanks

Ill check out your solution. I do ride in the rain quite a bit. Put a nicer windshield on it and ive ridden in the rain at 40 degrees and been fine (heated jacket) with only shins getting wet.
The lights have always come on when i turned the key on. It may be a "feature" that cuts low beam off at low battery. I think i jumpstarted it so that makes sense .

Ill look into the code reader. I found one "kit" i havent looked into
HEX Code GS911 3 Pin Interface | TwistedThrottle.com
Im willing to drop 100 .. but not 400-700.

I LOVE my k1200s but honestly if id known it was going to be a maintenance/repair pain in the ass id have gotten a k1000

Thank you both, a lot. Now off to find some frigging clutch fluid..
cdreid is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 K1200s Russel Cycle all day long seat for sale petar Accessories 0 Jul 28th, 2015 9:05 pm
05' & 06' K1200S Transmission Problems stevek1200s K12/1300S 14 Jul 13th, 2013 10:53 pm
2006 k1200s cam chain tensioner upgrade over 12k Steve-P Technical, Repair and Maintenance 8 Jul 11th, 2013 5:24 am
2006 K1200S Fuel Line Connectors baytown K12/1300S 6 Dec 23rd, 2011 5:57 pm
Buying A 2006 K1200s paulie64 K12/1300S 8 Feb 3rd, 2011 1:45 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome