lost me rocks - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old May 12th, 2010, 9:36 pm Thread Starter
Veteran
 
Papilio's Avatar
 
Join Date: Jun 2003
Location: Melbourne, Victoria, Australia
Posts: 1,163
lost me rocks

The bucket of rocks in the K has gone missing. All that I did was give it an oil change, I am sure that is not relevant.

The service centre told me once that with the older models they could tune out the noise, but not so with the newer models, allegedly self tuning. Maybe it has tweaked itself up and eliminated the noise. Like riding a sewing machine instead of an excavator.
.
Papilio is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old May 13th, 2010, 7:44 am
Rookie
 
04K12GT's Avatar
 
Join Date: Jun 2008
Location: Crozet, VA, USA
Posts: 49
Based on the title, I thought this was a confidence issue ...

2006 R1200GS - new to me May 2010
2004 K1200GT - KO by dump truck April 2010
04K12GT is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Box of Rocks? Saloman1 K1200RS/GT (Classic) 12 Sep 2nd, 2009 5:04 am
K75S - Help! - Lost cylinder...electrical? neilkamman Other K-Bikes Discussion 6 May 17th, 2009 8:46 pm
Healing and wheeling at Red Rocks Rendezvous 2008 rhhall Ride Tales 8 Sep 8th, 2008 8:51 am
My Bad...Lost left bag! coynerc K1200RS/GT (Classic) 9 Feb 3rd, 2006 5:51 pm
hard drive crash lost my attack of life spooky Bike Talk 2 Dec 20th, 2005 3:47 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome