Here's a different one - diagnostics system acting up - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Jul 21st, 2010, 5:30 pm Thread Starter
Member
 
Join Date: May 2008
Location: Fairfax, Virginia, USA
Posts: 66
Here's a different one - diagnostics system acting up

Tried to fire up the bike after work yesterday, but no luck. The computer and neutral light came on, but not the red to amber lights indicating that the bike was going through its pre-ignition diagnostic checks. No diagnostics, no start button. Tried it on and off for an hour and finally had the bike towed to the shop.

And as Murphy's law would have it, the bike worked perfectly at the shop. I'm sure that something intermittent like that will be hard to trace. It's the first time it's happened to me, but the mechanic said he's seen it happen on other bikes. And for the record, I have 15k on the bike.
RonP is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Jul 22nd, 2010, 12:00 pm
Sheep
Guest
 
Posts: n/a
Did you ever have the left and right combo switches done under recall? Intermittent non-starting was sign right one was going bad. Often gave no warning at all. I paid for my right one out-of-pocket to avoid being stranded as you were; I'm almost 170mi from nearest dealer, CapBMW. BMW faithfully reimbursed me at last service since the switches were under recall.
post #3 of 5 (permalink) Old Jul 22nd, 2010, 7:47 pm Thread Starter
Member
 
Join Date: May 2008
Location: Fairfax, Virginia, USA
Posts: 66
Switches were replaced about a year ago. It hasn't done it again, so I'll just keep an eye on it for now.
RonP is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old Jul 24th, 2010, 7:10 am Thread Starter
Member
 
Join Date: May 2008
Location: Fairfax, Virginia, USA
Posts: 66
The shop couldn't find anything wrong, so I picked it up Thursday night. Worked fine on Friday morning's ride into work, and - you guessed it - did it again Friday afternoon. It's going back into the shop.

There are some leftover '09 Yamaha R6's going for cheap around my way. They're looking very tempting right now.
RonP is offline  
post #5 of 5 (permalink) Old Jul 28th, 2010, 5:39 pm Thread Starter
Member
 
Join Date: May 2008
Location: Fairfax, Virginia, USA
Posts: 66
Problem solved. It was the right switchgear. It apparently wasn't replaced when the left one was because it was out of stock.

It's all moot now, because the bike's going up for sale when I get it back. Nice bike, but a lot more than I can legally use on the street. It was great for the ego, but I'm doing track days now and can get my need for speed taken care of on the track.
RonP is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Absolutely the most detailed description of the K1200S I've come across... sinc K12/1300S 20 Jul 19th, 2014 9:04 am
Interesting read on returnless type fuel systems JCW K12/1300R/R-Sport 2 May 17th, 2011 1:19 am
New ABS System and Advanced Stability Control Details eljeffe Bike Talk 0 Jul 16th, 2006 4:43 pm
Integral ABS and ASC - New Riding Dynamic Control Systems for BMW Motorcycles SilverRT K12/1300GT (Next Gen) 1 Jul 14th, 2006 3:09 pm
full system exhaust shootout evoluzione K12/1300S 31 Jun 28th, 2006 5:06 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome