ABS pump failure - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Nov 7th, 2014, 5:14 pm Thread Starter
Noob
 
Join Date: Nov 2014
Location: Fairfax, VA- VIRGINIA, United States
Posts: 2
ABS pump failure

I have a 2008 K1200s whose brake failure light is now on. Just before this happened I brought my bike in to the dealer for it's 18,000 mile service and recall updates At that time they also replaced the front brake pads. I am not saying the dealer caused my problem but maybe instead of it being the ABS motors brushes maybe it could be something brought on by the service and is an easier fix. It seems an ABS motor should have a better lifespan than this. So far I have seen posts on other sites which say that a battery low on voltage can bring this on. I have also seen you tube video on the subject where the motor is disassembled and new brushes installed. What a pain. The ABS motor attaches to a hydrolic block by peening the block to the motor which tells me that maybe it was not meant to be disassembled. I am considering not having it fixed as the brakes work ok without the ABS. Does anyone here have any insight into this problem?
AlanH is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Nov 13th, 2014, 1:20 pm
Noob
 
Join Date: Oct 2014
Location: HELENA, montana, usa
Posts: 10
Since all was well before you brouhgt it in for service, it is probably related to the brake work they did. They may have removed the wheel in whcih case the ABS sensor might not be in the exact postion it needs to be in. I would check that and if that is not it I wuld take it back to the shop and have them diagnose the problem.
fastbobby is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
K1200RS ABS pump not stopping robopoulos Technical, Repair and Maintenance 3 Dec 17th, 2015 3:09 pm
ABS Brake Failure, any ideas? jimshields K12/1300R/R-Sport 8 Sep 22nd, 2014 2:15 pm
ABS Pump Failure gasketdave K12/1300GT (Next Gen) 4 Nov 19th, 2012 3:24 pm
ABS pump failure Sabre2870 K12/1300GT (Next Gen) 2 Aug 2nd, 2011 1:11 pm
Abs Failure!!! Dadicool59 K12/1300GT (Next Gen) 11 May 17th, 2010 11:09 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome