2005 K12S Battery Issue.. - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Mar 4th, 2017, 1:30 pm Thread Starter
Noob
 
Join Date: Mar 2017
Posts: 1
2005 K12S Battery Issue..

Hey Folks, first time caller long time listener,

In October of 2016 i had an battery issue with this bike: Drove 800 miles over 2 days, day 3 red battery light comes on and bike starts. End of day 3 after sitting for 2 hours, ignition on, LCD turns on, go to crank -> dead. Bike needs boost to get started, runs normal for 160 miles until out of gas, get to gas station, turn off, fill up, battery dead.

Nov 2016 - New battery installed. BMW OEM AGM. Bike runs great. Problem goes away. No issues noted.

March 2017 - Left the bike outside for 5 days without running it. Key in ingnition, turn key, nothing. Battery dead. Got a boost, bike runs normally. let it run for 5 minutes. Left it cold for 10. Came back, turn key, nothing. Battery dead.

Weird.

Maybe unrelated: 5 days before this issue occured, gas gauge went from 3/4 full to 20 miles left to 0 miles left in about a 30 second time frame after running for 15 mins. Gas gauge level no longer works on the computer (shows 0 miles).
Another maybe unrelated: An ignition coil went bad on me (cyl 3) in Jan after sitting for 2 weeks (???). A pain to fix - but after fix and new coil - issue went away. Ran normal for 4 weeks until this battery issue came back.

Any suggestions? ABS Relay drawing power? How come it worked fine with new battery for 2 months? I would have expected problem to come back right away if it was something like my stator.
jerry1990 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle RPMs not hold steady in Operation TEMP, Probably coils issue - K12s 2007 erani99 K12/1300S 0 Aug 13th, 2015 7:34 pm
Battery Strong, not starting cobbler K1200RS/GT (Classic) 10 May 17th, 2015 12:20 pm
Weird Battery issue K-bikeKev K1200RS/GT (Classic) 10 Mar 28th, 2012 9:40 pm
BMW Motorrad Maintenance Charger Manual uglybuttugly K12/1300GT (Next Gen) 6 Dec 21st, 2009 7:53 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome