2008 K1200s - ?clutch problem - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Jul 30th, 2017, 1:23 pm Thread Starter
Noob
 
Join Date: Jul 2017
Posts: 1
Question 2008 K1200s - ?clutch problem

We have a 2008 K1200s and it''s just started with a problem!
Can only start the bike in neutral, won't start in gear and sometimes takes a few times to start in neutral.
Also sometimes losing the gear indicator.

We suspect it might be the clutch on its way out, has anyone had a similar problem and what was the outcome?
Any advice greatly received, thanks.
bikersmissus is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome