New Member: Strange Problem - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old May 23rd, 2018, 9:34 am Thread Starter
Noob
 
Join Date: May 2018
Posts: 3
New Member: Strange Problem

Recently I've noticed my K1300S has been down on power in all gears. If I rev high enough it will gain an unbelievable amount of power somewhere around 8k revs. It does this in all gears and when I say it gains an unbelievable amount of power, I mean it feels like someone's hitting a nitrous switch. Any guesses are welcome since I have no idea what would cause this. It has the Ak slip-on and a couple of years ago I installed a booster-plug. Other than that, I've disconnected the exhaust baffle.

Thanks for any help!
powrtrippin is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Jul 13th, 2018, 2:20 pm
Noob
 
Join Date: Mar 2016
Location: Yapton, Arundel, West Sussex, United Kingdom
Posts: 2
Hi,
When you say you have disconnected the exhaust baffle do you mean the butterfly flap in the exhaust or just taken the baffle out the end of the exhaust end can?
Daddiator is offline  
post #3 of 4 (permalink) Old Jul 22nd, 2018, 8:56 pm
Noob
 
Join Date: Jul 2018
Posts: 7
Arrow How HOT is the REAR BRAKE ROTOR?

Quote:
Originally Posted by powrtrippin View Post
Recently I've noticed my K1300S has been down on power in all gears. If I rev high enough it will gain an unbelievable amount of power somewhere around 8k revs. It does this in all gears and when I say it gains an unbelievable amount of power, I mean it feels like someone's hitting a nitrous switch. Any guesses are welcome since I have no idea what would cause this. It has the Ak slip-on and a couple of years ago I installed a booster-plug. Other than that, I've disconnected the exhaust baffle.

Thanks for any help!
You are describing to a "T" the experience I had after I discovered my Rear Brake had LOCKED DOWN but I couldn't let it sit where it was and HAD to OVER REV the engine to OVER POWER the braking till I could find a proper off street place to pull off. At a 5/6k rpm she started rolling with a little more ease BUT you couldn't come off it without SERIOUS DECELERATION [uncalled for I might add].
bikeknight52 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old Jul 23rd, 2018, 11:48 am Thread Starter
Noob
 
Join Date: May 2018
Posts: 3
I disconnected the baffle. I tested it without the slip-on to ensure it wouldn't move and I zip tied the swing-arm on the baffle into place. It's not going anywhere and it sounds fantastic!

Turns out it was the BoosterPlug I had installed. I guess it slowly crapped the bed. BMW service told me to remove it and test again before bringing it in and that was it. Wrote to BoosterPlug about it and am awaiting a reply.
powrtrippin is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Problem zxmark9r K1200RS/GT (Classic) 2 Jun 3rd, 2014 5:01 am
My bike is officially a POS !!!!! Stranded in Death Valley!!!! Robert_W K12/1300GT (Next Gen) 370 Mar 17th, 2011 8:03 am
Do you have an idle problem on your K brick? voxmagna Technical, Repair and Maintenance 8 Jan 17th, 2008 3:33 am
accelerator problem bluesrock57 K12/1300GT (Next Gen) 4 Oct 19th, 2007 3:15 am
K-Bikes Member's Favorite Dealers rickd Dealer Experiences 0 Dec 14th, 2005 1:00 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome