06 K1200S abs failure - K-Bikes.com - Excellence in Motion
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 41 (permalink) Old Mar 1st, 2019, 5:54 pm Thread Starter
Noob
 
Join Date: Feb 2019
Posts: 23
Garage
06 K1200S abs failure

Hi, my name is Keith and my current ride is a 2006 K1200S. Love the bike but am sadly loving it less these days. I'm experiencing ABS issues and am hoping to glean some good info here to keep me loving the bike for the foreseeable future. I'm right at the 18K service and now have the added bugaboo of a flashing red triangle and greatly reduced braking power. I spoke with the local dealer and they are speculating that the abs brake module is the likely culprit. No worries, it is only $2200 plus whatever the labor cost is to swap it out [criminy] Presently, I've ruled out the battery as the charge is close to 13v. Brake fluid is clear and not low and was changed out when i bought the bike in June 2017.

If anyone can shed some light on this subject I'm grateful for your insights or experiences. Another issue I have is finding local talent (any Alabama riders here) to wrench on the bike other than the dealer, and yes, I do understand that they are likely the only ones that has the correct diagnostic equipment. The dealer told me several bikes of this vintage have similar /same issues. I inquired as to how those customers remedied the problem. I was told that none opted to spend the money for the $2200 part and opted to disable the unit and go without abs. I doubt it is that simple but am open to understanding what that would involve. Thanks for letting me air it out abit and i welcome any constructive feedback you would care to share.

Regards,
Keith
Kietho is offline  
Sponsored Links
Advertisement
 
post #2 of 41 (permalink) Old Mar 2nd, 2019, 9:28 am
Noob
 
cclaypool16's Avatar
 
Join Date: Jun 2018
Posts: 24
Garage
Check wire

Check both front and rear abs sensors mounted on the wheels,make sure they are clean,also I had this problem had the error read by a friend that had bmw ista/d and showed open circuit on front abs
sensor.The wire is inside a plastic sheath kinda like heat shrink and the way it was routed up front attached to my steering the sheath was making a bend at a certain place and cut the wire into inside the
sheath,hope this makes sense
cclaypool16 is offline  
post #3 of 41 (permalink) Old Mar 2nd, 2019, 11:24 am Thread Starter
Noob
 
Join Date: Feb 2019
Posts: 23
Garage
thank you cclaypool16, i will have a look. Since my original post I've searched high and low and discovered some helpful and some hurtful info concerning this particular braking system. Anyway, I will post my results when I have the issue resolved for better or worse. Thanks again.
Kietho is offline  
Sponsored Links
Advertisement
 
post #4 of 41 (permalink) Old Mar 2nd, 2019, 1:25 pm
Noob
 
cclaypool16's Avatar
 
Join Date: Jun 2018
Posts: 24
Garage
Yes please do post your results,could help someone in the future,because these bikes are loved by many including myself
cclaypool16 is offline  
post #5 of 41 (permalink) Old Mar 3rd, 2019, 9:12 am Thread Starter
Noob
 
Join Date: Feb 2019
Posts: 23
Garage
Perhaps I just never noticed it but, I do not recall ever hearing the "servo whine" that I read about and watched in a youtube video. My bike does not make the whine. It was manufactured 11/2005 which clearly puts in the 1st generation/servo assist ABS. Is the servo part of the abs modulator? I'm assuming it is. Because I do not recall ever hearing the whine I suppose it is possible that it was swapped to the non -servo assist abs. If the rain lets up today i'm going to try and put eyes on the unit. Thoughts, comments are appreciated.
Kietho is offline  
post #6 of 41 (permalink) Old Mar 3rd, 2019, 12:22 pm
Noob
 
cclaypool16's Avatar
 
Join Date: Jun 2018
Posts: 24
Garage
Keith have a look at this thread :
https://forums.bmwmoa.org/showthread...op-light-issue

Also believe it or not rear bulb blown will cause this,low brake fluid level,you should hear your abs module make noise when applying the brake !
Someone near you have a GS-911 ?
cclaypool16 is offline  
post #7 of 41 (permalink) Old Mar 3rd, 2019, 1:18 pm Thread Starter
Noob
 
Join Date: Feb 2019
Posts: 23
Garage
No issues with my brake light. Not sure how to check the microswitch but I did alter the adjustment to no avail. I do not know anyone with a GS-911. Still raining here so I cannot id the abs unit i have. I know it should be gen1 but, in the 1.5 years having the bike I do not recall hearing that whine. I normally have my helmet on and suited up before I start the bike but its hard for me to believe I would not have noticed the whine. If I have the abs that should come with this bike I guess the dealer is my next stop to run a diagnostic on the brake system.
Kietho is offline  
post #8 of 41 (permalink) Old Mar 4th, 2019, 7:24 pm
Noob
 
Join Date: Mar 2019
Posts: 2
Rebuild

https://modulemaster.com/rebuilds/

These guys have been gearing up to rebuild the K1200S ABS unit, but it looks like it's still not available for 2004- 2006 models. I was waiting for them to announce availability for the unit on my 2005 K1200S, but since the bike was totaled last week by a cager, it's no longer necessary. (I'm fine, thanks to Aerostich, Sidi and Rukka, and now have a 2012 K1300S courtesy of the cager's insurance company) My BMW dealer was happy to remove the ABS unit and send it to Module Master once the service was available.
AvidRider is offline  
post #9 of 41 (permalink) Old Mar 4th, 2019, 11:34 pm Thread Starter
Noob
 
Join Date: Feb 2019
Posts: 23
Garage
Glad your okay and am sure you will enjoy the K1300S. Thanks for the info.
Kietho is offline  
post #10 of 41 (permalink) Old Mar 5th, 2019, 9:25 am
Noob
 
cclaypool16's Avatar
 
Join Date: Jun 2018
Posts: 24
Garage
Yes for sure,first thing is get error read and then you can make a plan of action and know more where exactly the problem lies !!
cclaypool16 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
08 K1200S ABS wiring ashc2025 K12/1300S 0 May 6th, 2018 11:41 am
BMW K1200S CRASH - ABS servo system failure? whitedove K12/1300S 53 Mar 18th, 2018 10:56 am
K1200s ABS Modulator failure Brushfox K12/1300S 2 Apr 12th, 2015 6:31 am
ABS Brake Failure, any ideas? jimshields K12/1300R/R-Sport 8 Sep 22nd, 2014 2:15 pm
Abs Failure!!! Dadicool59 K12/1300GT (Next Gen) 11 May 17th, 2010 11:09 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome