Clock display changes with key turned to on. - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Oct 20th, 2007, 7:30 pm Thread Starter
Noob
 
Join Date: Jul 2007
Location: , ,
Posts: 5
Clock display changes with key turned to on.

I've got a strange problem with an '04 K12RS. For some reason the display on the clock changes often when the key in the ignition is turned to "ON". For example the clock may display 4:40 and then after turning the key it will say 21:20. It doesn't always do it but often enough where it is not reliable. The shop said it was indicative of a bad battery, they checked it and said it was bad and then replaced it but the problem persists.

Anyone else seen this problem?

Thanks
mbach is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Oct 20th, 2007, 8:32 pm
Veteran
 
Join Date: Jul 2004
Location: , SoCal., USA
Posts: 1,507
I had that problem when I installed a HID low-beam conversion kit purchased in our January '07 group-buy. Moving the ballast to the left side of the dash, mounting the igniter under the center dash bracket and all high voltage wiring away from the clock module cured the problem. Generally get anything that can induce a voltage into the clock wiring or module has to be re-located away.

Bruce C
'04 K1200RS Capri Blue(totaled)
2008 Triumph Sprint ST
brucecha is offline  
post #3 of 4 (permalink) Old Oct 21st, 2007, 7:14 am Thread Starter
Noob
 
Join Date: Jul 2007
Location: , ,
Posts: 5
Thanks for the suggestion Bruce, I've got the HID installed too. That makes sense. Another suggestion was to replace the fuse for the clock. After I make the changes I'll post the outcome. Thanks.
mbach is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old Oct 21st, 2007, 7:54 am
Veteran
 
Join Date: Jul 2004
Location: , SoCal., USA
Posts: 1,507
Quote:
Originally Posted by mbach
Thanks for the suggestion Bruce, I've got the HID installed too. That makes sense. Another suggestion was to replace the fuse for the clock. After I make the changes I'll post the outcome. Thanks.
I forgot to mention;
Do not tape any of the HID wiring to the stock wiring harness. Try to cross the stock wiring at 90.

Bruce C
'04 K1200RS Capri Blue(totaled)
2008 Triumph Sprint ST
brucecha is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Retaining the BC (Onboard Computer) Display Setting Between Starts XMagnaRider K12/1300GT (Next Gen) 18 Oct 2nd, 2007 10:47 pm
Display intensity KLAPTRAPPER K12/1300GT (Next Gen) 12 Oct 31st, 2006 4:55 pm
Oil Display iangill K12/1300GT (Next Gen) 10 Oct 9th, 2006 11:55 pm
K1200RS Digital Display problem SteveN Technical, Repair and Maintenance 7 Apr 15th, 2006 6:48 pm
Computer display Bob1949 K12/1300S 6 Nov 9th, 2005 11:41 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome