gear indicater malfunction - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Sep 9th, 2007, 9:53 pm Thread Starter
Noob
 
scottnews41's Avatar
 
Join Date: Aug 2006
Location: Canton, GA, USA
Posts: 26
gear indicater malfunction

Has any one replaced their gear indicater switch? The shop quoted me $250 to fix mine.
scottnews41 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Sep 11th, 2007, 1:38 pm
Noob
 
80465KRS's Avatar
 
Join Date: Dec 2006
Location: Morrison, CO, USA
Posts: 14
You might try these threads for clues on how to diagnose the problem yourself? I did a site search on "gear indicator" because I knew I had seen someone else post about a problem.

http://www.k-bikes.com/forums/showthread.php?t=11037

http://www.k-bikes.com/forums/showthread.php?t=1933

2001 K1200RS, 1964 R69S
80465KRS is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
OIL? Engine oil or tranny (gear oil) or the same thing? 9Roqit K12/1300R/R-Sport 6 Aug 30th, 2007 12:17 am
Rhinewest Cam Gear Install Troubles macdonge Technical, Repair and Maintenance 5 Apr 22nd, 2007 7:33 pm
Rhinewest Cam Gear Install Troubles macdonge K1200RS/GT (Classic) 6 Dec 15th, 2006 8:35 pm
Trouble getting it into first gear. hazard K12/1300GT (Next Gen) 9 Sep 23rd, 2006 9:37 pm
Are you having problems using your heated gear? gsdave K12/1300S 4 Dec 28th, 2005 6:56 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome