Out of control throttle - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Jul 28th, 2009, 3:58 pm Thread Starter
 
Join Date: Jul 2009
Posts: 5
Out of control throttle

I just reinstalled the fuel tank on my '03 K12GT after replacing the fuel filter. Had the battery out for some other work so after bolting in the tank and re-installing the battery, I reset the TPS.

Turned on the ignition and the engine ran straight up to 8000 rpm. Shut it down before it red-lined. Inspected the throttle cables and they don't appear to be hung up, pinched or mal-connected anywhere. I thought I did something wrong when resetting the TPS so I removed the battery and called it a day.

This morning after re-installing the battery I again reset the TPS and the same problem occured. Removed the fuel cell again and inspected underneath it for other signs but found nothing.

I've checked the hoses (twice) and they all appear to be installed correctly.

I can get the RPM's to go down to 5000 by forcing the throttle handle more (?) closed. Odd.

What the hell have I done?
Motomonk is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Jul 28th, 2009, 5:17 pm
 
Join Date: Jul 2008
Posts: 27
If you have to force the throttle cable to close it so that the revs drop to 5000rpm's it would suggest the throttle cable is too tight, either trapped or twisted in some way. Are you sure the tank is not trapping the throttle cable? I would look there.

Does this one have cruise control? If it does that would explain why the revs drop when you force it closed. The cruise control cable is trying to close the throttle and the throttle cable is trying to keep it open. What other work did you do when you removed the battery?
sundancer is offline  
post #3 of 3 (permalink) Old Jul 28th, 2009, 9:11 pm Thread Starter
 
Join Date: Jul 2009
Posts: 5
fixed it

Couldn't see the forest for the trees. It was the cable coming directly from the cruise control unit which had been forced out of position by my autocom box.

feeling like a noob....
Motomonk is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Performed the fettle tonight Nexus-6 K12/1300GT (Next Gen) 78 Feb 1st, 2015 8:02 pm
Absolutely the most detailed description of the K1200S I've come across... sinc K12/1300S 20 Jul 19th, 2014 9:04 am
CIP 11.0 Is Out eljeffe Bike Talk 2 Mar 4th, 2008 10:17 pm
Kaoko Throttle Control mjptexas K12/1300R/R-Sport 7 Jan 19th, 2008 9:57 pm
Integral ABS and ASC - New Riding Dynamic Control Systems for BMW Motorcycles SilverRT K12/1300GT (Next Gen) 1 Jul 14th, 2006 3:09 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome