heated grips not working 02 rs any suggestions - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old May 12th, 2010, 1:20 pm Thread Starter
Rookie
 
Join Date: Mar 2010
Location: goshen, ct, usa
Posts: 32
heated grips not working 02 rs any suggestions

the heated grips are not working on my rs. the fuse is good
neither grip heat works so i am leaning toward the switch as the culprit.
any ideas of where to start and what to test would be a great help
bke7 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old May 12th, 2010, 4:41 pm
Veteran
 
Join Date: Jul 2004
Location: , SoCal., USA
Posts: 1,507
Both the left and right heated grip go to a common electrical connector near the headstock. This connector is known to get some corrosion. Check for voltage there first.
Be careful removing the spade connectors from this connector. The grip wires are very thin. Also check the resistance of each individual pair of grip wires while you have them disconnected.

Bruce C
'04 K1200RS Capri Blue(totaled)
2008 Triumph Sprint ST
brucecha is offline  
post #3 of 6 (permalink) Old May 13th, 2010, 5:45 am
Rookie
 
Kurgan's Avatar
 
Join Date: Sep 2009
Location: Hamilton, Ontario, Canada
Posts: 53
If you look into the "void" behind your fairing, in front of the the "gas tank" you will notice that the heated grip wires are connected to a plug/junction. Check the integrity of the connection. I can't imagine what else it could be.

If your stock grips are starting to crack/fall apart, you might find it a good time to carefully peel off the stock grips and inspect the heating elements. Most 1 inch aftermarket gel grips are effective replacments.

2015 Yamaha SMAX (XC155) -- "battle scooter"
Looking at BMW again... what to buy?
Kurgan is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old May 14th, 2010, 7:40 am Thread Starter
Rookie
 
Join Date: Mar 2010
Location: goshen, ct, usa
Posts: 32
i will look at the connection today thank you
bke7 is offline  
post #5 of 6 (permalink) Old May 16th, 2010, 9:05 am Thread Starter
Rookie
 
Join Date: Mar 2010
Location: goshen, ct, usa
Posts: 32
i cleaned the connection and reassembled works just fine now
thank you
bke7 is offline  
post #6 of 6 (permalink) Old May 16th, 2010, 11:55 am
Veteran
 
Join Date: Jul 2004
Location: , SoCal., USA
Posts: 1,507
Quote:
Originally Posted by bke7
i cleaned the connection and reassembled works just fine now
thank you
Good deal!!!!!

Bruce C
'04 K1200RS Capri Blue(totaled)
2008 Triumph Sprint ST
brucecha is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Replacing heated grips dohalloran K1200RS/GT (Classic) 5 Sep 7th, 2009 8:22 pm
Removing Heated Grips on K1200S: Need Advice Pirate K12/1300S 26 May 4th, 2009 8:28 pm
Heated grips bpbiker Other K-Bikes Discussion 4 Apr 11th, 2009 6:48 pm
heated grips not working chuckheinch K12/1300R/R-Sport 2 Dec 1st, 2007 1:13 am
Heated grips controlled by the onboard computer - rubbish ? wadham K12/1300GT (Next Gen) 24 Oct 4th, 2006 9:53 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome