2001 k1200rs dash problems - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Sep 23rd, 2017, 4:40 pm Thread Starter
Noob
 
allannorman's Avatar
 
Join Date: Sep 2017
Posts: 1
2001 k1200rs dash problems

Hi, bought a k1200rs about 2 months ago, and I absolubtly love it to be honest, it's a high mileage example but well cared for.

Now my problem is this, the abs warning lights don't come on when I start the bike, I also don't have a working fuel guage and my clock and gear indicator are not working. I've checked all the fuses and all are fine. I thinks it's too much of a coincidence for multiple wires to have frayed, and I think it's all related, that's my thinking anyway

I am a qualified mechanic, and work as a bike mechanic in a small Indi shop but we don't really touch anything like BMW's so I'm completly new to both riding and working on them, although I don't mind getting stuck in and getting my hands dirty.

This has been doing my nut in since I bought it and if anyone could shed some light on the problem is appreciate it

Cheers
allannorman is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Jun 9th, 2018, 7:32 pm
Noob
 
Join Date: Jun 2016
Location: , , Scotland
Posts: 3
Did you ever find the issue? I have similar problems the oil, temp and battery lights are not coming on at startup as they should and I have no neutral light or gear indicator.

I suspect part of the issue is the sidestand switch, for the past 2 days the gear indicator and neutral light were playing up and a wiggle of the sidestand brought them back.

I'm hoping the warning lights not coming on is something to do with the startup tests and no functioning sidestand switch.

This fiasco all started when my starter relay failed and the starter kept trying to spin up. Both starter and relay were replaced, worked fine then the gremlins as mentioned above started.

Also the clock and gear indicator - the white block connector in the electronics box (right side behind fan cowl) will likely have a corroded pin that has come apart. Clock and gear indicator power are both off the same pin. I found the corroded pin...which was missing as it had rotted away and used a bit of wire to bypass the connector on that wire.
MachineHead is offline  
post #3 of 3 (permalink) Old Jun 11th, 2018, 3:24 am
Noob
 
Join Date: Jun 2018
Posts: 4
Quote:
Originally Posted by MachineHead View Post

Also the clock and gear indicator - the white block connector in the electronics box (right side behind fan cowl) will likely have a corroded pin that has come apart. Clock and gear indicator power are both off the same pin. I found the corroded pin...which was missing as it had rotted away and used a bit of wire to bypass the connector on that wire.
All my lights work but I have a similar problem with the clock and gear shift have have been wondering how to fix it. I guess it's off with the fairing (but thanks for the tip)...!
Chazmania is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Barn Find! Yellow 2001 K1200RS Aggie86 K1200RS/GT (Classic) 4 Feb 8th, 2017 9:09 am
Pre 2001 K1200RS turn signal pod alternative? eurobikefan K1200RS/GT (Classic) 4 Aug 14th, 2014 10:54 am
FS: 2001 BMW K1200RS in Denver Morr Bikes 1 Jul 27th, 2013 6:39 pm
K1200RS 2001 Intermittent ABS brake failure nozza2520 Technical, Repair and Maintenance 3 Sep 10th, 2011 6:37 am
Any major problems with 2001 RS (produced in 09/2000)???? kopov260 K1200RS/GT (Classic) 6 Sep 10th, 2009 9:28 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome