'98 KRS speedo not working, headlight stays on. Load shed relay? - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Sep 9th, 2018, 4:48 pm Thread Starter
Noob
 
Join Date: Apr 2016
Location: Hudson, New York, United States
Posts: 7
'98 KRS speedo not working, headlight stays on. Load shed relay?

Trying to chase down few things: speedo worked intermittently, then finally packed up and doesn't move.

I checked the FD sensor, wiring connections under the seat, and all looks good.

Now have an issue where the headlight stays on after turning the bike off. I've now noticed that if the temp gauge goes down to "zero", then turning the ignition on/off ultimately turns the headlight off.

Also (unrelated?) gear indicator and clock lcds don't read.

Could all, or part of this be related to a crapped out "load shed relay"?

If so, where is this thing? I took the tank off, and couldn't find it where it should be, according to some pics I've seen.

Is it located next to the air filter, or is it on the right side of the bike, behind the smaller panel (behind the fan duct), or the larger panel behind that?

Also noticed that there aren't fuel line quick disconnects. Is this stock for '98, or did the previous owner remove them?

Thanks in advance for thoughts.

Last edited by freccia; Sep 10th, 2018 at 4:00 am.
freccia is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Sep 14th, 2018, 7:16 pm
Member
 
jskene1's Avatar
 
Join Date: Aug 2005
Location: , VA, USA
Posts: 83
The load relief relay is in the electrical equipment box under the tank on the right side.

See diagram below.

My bike did not come with quick disconnects.




____________________________________________________________________
P3 Lights - Programmable Triple-Function Rear Light: Be Conspicuous
Photon Blaster - High Intensity Front Safety Lights: Can you see me NOW
____________________________________________________________________
jskene1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedo not working after ABS removal congadude K1200RS/GT (Classic) 18 May 8th, 2013 10:00 pm
Bulb Question Yoda K1200RS/GT (Classic) 31 Aug 30th, 2010 6:53 pm
2003 K1200GT headlight stays on !!!! Help!! Kevmule K1200RS/GT (Classic) 8 Aug 20th, 2010 12:03 pm
Help with Headlight Relay Installation paulstamser Other K-Bikes Discussion 8 Apr 29th, 2010 12:20 am
Headlight not working Hooligan K12/1300R/R-Sport 9 Aug 20th, 2008 12:25 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome