'02 k1200RS with non-working cruise - K-Bikes.com - Excellence in Motion
 1Likes
  • 1 Post By sailor
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old May 22nd, 2019, 11:36 pm Thread Starter
Noob
 
Join Date: May 2019
Posts: 12
Garage
'02 k1200RS with non-working cruise

I bought my K12 in August. I took it out for a nice highway run and found I couldn't set the cruise.

Not having owned a BMW, how difficult is it to trouble shoot a cruise issue? I bought a Clymer manual, so I have all the electrical diagrams.

Thanks.
t100angel is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old May 23rd, 2019, 5:42 am
Addict
 
Join Date: Jun 2003
Location: Montreal, QC, Canada
Posts: 460
Quote:
Originally Posted by t100angel View Post
I bought my K12 in August. I took it out for a nice highway run and found I couldn't set the cruise.

Not having owned a BMW, how difficult is it to trouble shoot a cruise issue? I bought a Clymer manual, so I have all the electrical diagrams.

Thanks.
The cruise-control main unit has been very reliable (in general) - most issues are related to many micro-switches (clutch, brakes and throttle ramp). To help troubleshoot the system, they have included a simple/crude diagnostic mode in the system.

See this link on YouTube for a troubleshooting tutorial:
http://youtu.be/2ov3-jdII6A?hd=1

When I did this video in 2011, I was convinced that Video was the best medium to convey all the information I had in mind. HOWEVER, I am well aware that it is not the best way to keep this info available near your toolbox or your shop manual to run the steps in the garage.

To compensate for this, I have attached a text summary (in PDF format) with this message.
Attached Files
File Type: pdf K1200_CruiseConrol_troubleshooting(version 1-3).pdf (362.3 KB, 23 views)
t100angel likes this.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
John (Montreal, CANADA)
K1200RS (2002 IceBlue/Red - 96,000 miles)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
sailor is offline  
post #3 of 5 (permalink) Old Jun 23rd, 2019, 11:17 pm Thread Starter
Noob
 
Join Date: May 2019
Posts: 12
Garage
Thanks much. When I slide the switch I do see a red light under the slider. Is a red light normal or does that indicate an issue?

I'm in the process of sanding down scratches in the faring so I can prime and paint it. Once that's done it goes in for a safety inspection after the crash.

So excited to get out on the road this year.

T100angel.
t100angel is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old Jun 24th, 2019, 8:18 am
Addict
 
Join Date: Jun 2003
Location: Montreal, QC, Canada
Posts: 460
Quote:
Originally Posted by t100angel View Post
Thanks much. When I slide the switch I do see a red light under the slider. Is a red light normal or does that indicate an issue?

I'm in the process of sanding down scratches in the faring so I can prime and paint it. Once that's done it goes in for a safety inspection after the crash.

So excited to get out on the road this year.

T100angel.
YES , the REd LED light under cruise ON-OFF (slider switch) is normal.
Did you follow the video and printed pages instructions to execute the diagnostic routine ? This should give you a good starting point where to look to solve the issue.

OF COURSE, no one will care about the cruise-control working or not for the safety inspection ;-)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
John (Montreal, CANADA)
K1200RS (2002 IceBlue/Red - 96,000 miles)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
sailor is offline  
post #5 of 5 (permalink) Old Jun 24th, 2019, 4:39 pm Thread Starter
Noob
 
Join Date: May 2019
Posts: 12
Garage
I have not yet. I'm working on faring repairs after a minor crash. The cruise, while nice, is not highest priority. Getting faring back on the bike, and a safety check come first. Then I will troubleshoot the cruise.

Thanks!
t100angel is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
'02 k1200RS with non-working cruise t100angel Technical, Repair and Maintenance 1 May 25th, 2019 2:39 pm
03 K1200RS "Euro" headlight switch not working? Proteus K1200RS/GT (Classic) 3 May 3rd, 2019 9:08 am
Cruise control quit working armandanvil K1200RS/GT (Classic) 5 Jun 16th, 2017 9:13 pm
Cruise control K1200rs problem trebor99 Technical, Repair and Maintenance 1 Jul 7th, 2015 1:02 pm
OEM Cruise control for 2005 K1200RS bamadays K1200RS/GT (Classic) 11 Aug 31st, 2012 5:40 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome