Hyperpro update? - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old May 17th, 2007, 9:35 am Thread Starter
Member
 
GJBushman's Avatar
 
Join Date: Oct 2005
Location: Montgomery Village, MD, USA
Posts: 76
Hyperpro update?

I am chomping at the bit for new shocks (22K). I was all set to pull the trigger on Wilbers and then Klaus' arrangment fell apart. Anyone out there in K-bike land running Hyperpro shocks? What are your experiences?

Jamie
GJBushman is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old May 17th, 2007, 10:03 am
Addict
 
The Fllash's Avatar
 
Join Date: Jan 2005
Location: Las Vegas, Nevada, USA
Posts: 513
I put a set of Works on 5 months ago and lovem. Cost for both was about $1,100 for the set. Took about 1/2 hour to order with all the Q's they asked to set the shocks for my style of ridding. They did all the set up I just installed, easy to do.

I did have two installation problems with the rear:
The lower mount radius on the shock was too small and I had to grind down the radius on the drive tube.
The hight adjusting knob valve hose fitting had to be rotated 180 and I had to have the shock recharge with nitrogen for $10. local.

These shocks can be rebuit.

Bazra
aka: The Flash
The Fllash is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Pipenslippers post crash update pipenslippers K12/1300GT (Next Gen) 5 Sep 6th, 2006 4:20 am
Just had 600 mi service with software update RoadKing K12/1300S 6 Aug 19th, 2006 8:48 am
6.0.1 Software Update eljeffe K12/1300S 0 May 10th, 2006 8:41 pm
CIP CD 6.0 Update eljeffe K12/1300S 10 Apr 23rd, 2006 6:55 pm
Software update glitch? wyeknott K12/1300S 21 Nov 18th, 2005 1:44 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome