So stoked! BMW replaced my ECU today... - K-Bikes.com - Excellence in Motion
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old Jun 10th, 2007, 12:20 am Thread Starter
Rookie
 
Join Date: Oct 2006
Location: Menlo Park, CA, USA
Posts: 57
So stoked! BMW replaced my ECU today...

About 6 weeks ago I purchased an '04 K1200GT with 1233 miles on it. Very nice upgrade from my '02 KRS.

Anyhow, I discovered shortly after I purchased it that it had the cold-start issue. Some days I had to start it several times, other times it would just die when I touched the throttle when cold. Riding was not an option for a few minutes after starting.

Today I had the ECU swapped out under warranty! Apparently BMW will still perform the work under the original warranty (mine expires next March).

Some other things I noticed:

-The buzz at 3500-4500 rpm is greatly reduced. No more numb hands!
-It idles higher
-It smells like it runs richer
-Throttle response is better

Overall I'm totally happy. Now I am reconsidering the RW chip! Why mess with a good thing?

2010 Street Glide
2007 DRZ400S
JCleary is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old Jun 10th, 2007, 10:04 am
 
Join Date: Apr 2005
Posts: 85
Quote:
Originally Posted by JCleary
About 6 weeks ago I purchased an '04 K1200GT with 1233 miles on it. Very nice upgrade from my '02 KRS.

Anyhow, I discovered shortly after I purchased it that it had the cold-start issue. Some days I had to start it several times, other times it would just die when I touched the throttle when cold. Riding was not an option for a few minutes after starting.

Today I had the ECU swapped out under warranty! Apparently BMW will still perform the work under the original warranty (mine expires next March).

Some other things I noticed:

-The buzz at 3500-4500 rpm is greatly reduced. No more numb hands!
-It idles higher
-It smells like it runs richer
-Throttle response is better

Overall I'm totally happy. Now I am reconsidering the RW chip! Why mess with a good thing?
That's good to know as I questioned BMW about the need to do the ECU 'swap' on my 2004 KGT back when this first hit the fan. BMW confirmed what my dealer had told me, when I called their 800-number, that my VIN wasn't in the affected range. Since I wasn't experiencing any of the ill-effects of a 'bad' ECU I left it at that, with a few lingering reservations as I know of a few others who had sucessfully pursued the swap as a 'preventative' measure...
motorradnik is offline  
post #3 of 11 (permalink) Old Jun 10th, 2007, 5:33 pm
Enthusiast
 
DangerMoney's Avatar
 
Join Date: Sep 2004
Location: Tucson, AZ, USA
Posts: 284
What 800 number do you call? I've got an '04 K1200RS. When I had the bike in Flagstaff overnight it stalled a lot the next morning. Down here in the heat of Phoenix I don't notice it.

Bill

'04 K1200RS Alpine White/Orient Blue
'05 R1200GS Red
'07 KTM 950 Super Enduro
DangerMoney is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old Jun 10th, 2007, 9:51 pm Thread Starter
Rookie
 
Join Date: Oct 2006
Location: Menlo Park, CA, USA
Posts: 57
I noticed the problem the second day I had it. I brought the bike in for a service shortly thereafter. I had done some research and discussed the problem with the service manager.

It took him a week or two, but he finally called me back. He had done some research and located the original bulletin. He then ran my VIN to verify it fell within the range required the update. Once he verified the VIN, he ordered the part.

I took the bike in yesterday. They changed the ECU and changed the oil. They even gave it a good wash.

In the meantime, I was out on one of their loaner R1150R having a blast! 110 miles of twisty fun!!!

Overall, a great experience.

I think you should talk to your local service manager and tell him it runs rough on a cold start and dies when you touch the throttle (if that's indeed what it's doing). Mine would not run right on a cold start, even on a hot day.

2010 Street Glide
2007 DRZ400S
JCleary is offline  
post #5 of 11 (permalink) Old Jun 11th, 2007, 5:46 pm
 
Join Date: Apr 2005
Posts: 85
Quote:
Originally Posted by DangerMoney
What 800 number do you call? I've got an '04 K1200RS. When I had the bike in Flagstaff overnight it stalled a lot the next morning. Down here in the heat of Phoenix I don't notice it.
1-800-831-1117 ask about TSB 1300204.57 you will need your VIN #...

From an earlier post I made regarding this issue on Oct 28th, 2005:

"Does anyone know when the start date is supposed to be for the bad ECU's? I called BMWNA customer service (1-800-831-1117) and gave them my VIN# and build date of 09/03 for my '04 KGT and was told it was not in the date range affected by TSB 1300204.57 ... I haven't noticed any severe symptoms w/ slow throttle response or erratic idle (yet) but don't want to be left behind after the cutoff if there's a possibility that I might have a defective ECU. Gas mileage has been anywhere from low 30's to low 40's depending on how 'spirited' I've ridden off that tank-full. Generally fast backroads riding in 4th and 5th will net low to mid-30's; more constant-speed touring in 5th and 6th will see low to mid 40's. Is this in line w/ 'normal' mileage figures for the K/GT? Anyone else in the general build date of my bike been told anything different? Thanks!"

Read the entire thread here ---> http://www.k-bikes.com/forums/showthread.php?t=774
motorradnik is offline  
post #6 of 11 (permalink) Old Jun 13th, 2007, 7:42 am
 
Join Date: Apr 2006
Posts: 1
ECU replaced!

My ECU in my 03 RS was replaced by Miller BMW in Tallahasee under warranty after they tried to start it and ride it cold. Before that the mechanic just passed it off with a "they all do that." With the new ECU I now get 45 mpg, up from 39 mpg. It feels more responsive and now can be driven immediately after starting. Get it done if you have starting problems.

Ken
2003 K1200RS Zebra

KenB is offline  
post #7 of 11 (permalink) Old Jul 9th, 2007, 5:20 pm
Rookie
 
04GTRider's Avatar
 
Join Date: May 2007
Location: , NE, USA
Posts: 37
I have an 04 GT I bought about a month ago and have been reading over this ECU issue. I have not had problems with this bike and BMW wont even entertain the thought of replacing something that isnt broken. Is EVERY bike eventually effected by this ECU problem? I tend to agree that if there is nothing wrong with it, that there is no reason to replace it. I am under warranty till August 08'. Were there certain bikes made at a certain time that were effected? My bike was a late 04' model w/o the heated grips/seat and elctronic cruise. I suspect if there is a problem I will notice it this fall. Any further thoughts from anyone on this?
04GTRider is offline  
post #8 of 11 (permalink) Old Jul 9th, 2007, 5:46 pm
Looking for better limits...
 
Razel's Avatar
 
Join Date: Jun 2003
Location: Fremont, CA, USA
Posts: 5,163
Not all of the bikes were affected. What got BMW's panties all up in a bunch was while they realized some of the ECU's were a problem, not all of them were, and people were jumping on the "preventative" bandwagon, with BMW eating the cost of replacing some ECU's that were fine. Then the pendulum started swinging the other way and a lot of pushback toward the customers regardless of the problem being there. It appears to have gotten sorted out by telling the dealer the bike had a cold-start issue just off throttle. Some were satisfied with that complaint to go forward, others kept the bike overnight to confirm it. I wouldn't be real surprised that BMW tested the returns, tossed the bad ones, and put the good ones back into the parts bin. I don't recall if anyone ever found out the real cause, though.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

Ray
2010 K1300GT Royal Blue
2003 K1200GT Orient Blue (for sale)
2007 G650 X-Challenge

IBA #34158

Be a K-Bikes Supporter

I work for Keyser SŲze
Razel is offline  
post #9 of 11 (permalink) Old Jul 9th, 2007, 10:41 pm
Member
 
barnburner's Avatar
 
Join Date: May 2007
Location: Kansas City, MO, USA
Posts: 70
Mine is going through it right now. Stealer, oops, I mean dealer is "getting with BMW" to get mine replaced while it's under warranty. I should know something by the middle of next week. For the money I paid, it better be replaced on BMW.
barnburner is offline  
post #10 of 11 (permalink) Old Jul 9th, 2007, 11:39 pm
Rookie
 
04GTRider's Avatar
 
Join Date: May 2007
Location: , NE, USA
Posts: 37
Well, I have a SLIGHT pause when blipping the throttle when starting it when it is cool outside. Clears up quickly after I get going. Is what is experienced with a bad ECU? I guess I will wait till fall and see how it goes. I talk to BMW via the number posted somewhere in this message and they say if it isnt a problem, they arent replacing it. Thanks for all the info and I will report back on what happens.

Pat
04GTRider is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Absolutely the most detailed description of the K1200S I've come across... sinc K12/1300S 20 Jul 19th, 2014 9:04 am
BMW North America Sells Motorcycle Division??? tedshred Bike Talk 2 Apr 1st, 2007 7:41 pm
BMW Group sets new worldwide sales record in 2006 eljeffe Bike Talk 0 Jan 8th, 2007 1:27 pm
French Test of K1200GT eljeffe K12/1300GT (Next Gen) 12 Jun 17th, 2006 6:25 pm
Lost My BMW Top Case - BMW Replaced craigj K1200RS/GT (Classic) 8 Feb 16th, 2006 9:57 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome