Tail light assembly install - help - K-Bikes.com - Excellence in Motion
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old Jun 11th, 2008, 9:13 pm Thread Starter
 
Join Date: Jun 2008
Posts: 468
Tail light assembly install - help

Installed my Kisan brake light bulbs tonight. Went to reinstall the tail light assembly and it's all loose. The top post/grommet goes together but seems really loose. Even with the screws tightened on the bottom the whole assembly is loose and wobbles. The housing is not flush all the way around either (by the blinkers).

Did I miss something? I took it off/reinstalled it about 5 times, trying to find what I missed. It was snug as a bug when I first disassembled it, took some effort to pull apart. All the rubber and posts are fine, nothing is interfereing with the housing, screws are good.

Please, help!
iflybricks is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old Jun 12th, 2008, 7:45 am
Member
 
Join Date: Jul 2005
Location: , IL, USA
Posts: 75
Same issue for me, but I noticed the taillight assembly was wobbly before I removed it to install the Kisan. I'm thinking it's TADT (they all do that), because I remember reading similar posts on this site or others.

I'm getting the flashing yellow lamp warning when I apply the brakes right after startup, but it goes away after a few seconds. Andy at Kisan explained it as resulting from diminshed battery voltage after cranking , but said it is of no concern.

I'm going in for the 12k service on Monday, so I'll ask the tech about both issues and report back if I hear anything different.

Bud
2006 K1200GT - Graphite
gc916 is offline  
post #3 of 11 (permalink) Old Jun 12th, 2008, 10:46 am
Strafist
 
grifscoots's Avatar
 
Join Date: Aug 2006
Location: Outside New Braunfels, TX, USA
Posts: 2,544
It's wobbly.

-=grif=-
What was that middle thang?
grifscoots is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old Jun 12th, 2008, 6:27 pm Thread Starter
 
Join Date: Jun 2008
Posts: 468
600 mile break-in service tomorrow am. I'll ask the techs.

I knew I wasn't crazy!
iflybricks is offline  
post #5 of 11 (permalink) Old Jun 12th, 2008, 6:29 pm Thread Starter
 
Join Date: Jun 2008
Posts: 468
Quote:
Originally Posted by gc916
Same issue for me, but I noticed the taillight assembly was wobbly before I removed it to install the Kisan. I'm thinking it's TADT (they all do that), because I remember reading similar posts on this site or others.

I'm getting the flashing yellow lamp warning when I apply the brakes right after startup, but it goes away after a few seconds. Andy at Kisan explained it as resulting from diminshed battery voltage after cranking , but said it is of no concern.

I'm going in for the 12k service on Monday, so I'll ask the tech about both issues and report back if I hear anything different.

They had a note in with my install instructions. Here's my post in another thread about my Kisans.

Installed, worked okay. Rode all day (300 miles). Don't work okay.

After the install they were flawless. After a couple hours I noticed I only got the flashy triangle thingy intermittently. At one stop light I applied the brakes and didn't see the yellow triangle warning. At the light I turned around and looked at the lens - no flash. The tail light was fine, brake light came on solid. Weird.

Also, after one fuel stop I got the lamp warning on the tail light. No lights, no brake lights. Key off, then back on fixed the problem.

It appears the Tail Blazers work fine at startup, then during the ride stop flashing, or only flash a couple times, then come on solid. I have no earthly idea what the don't work all the time, or not work all the time.

Intermittent problems are the worst.


Anyone? Anyone? Bueller? Bueller? Bueller? Frye? Frye?
__________________
iflybricks is offline  
post #6 of 11 (permalink) Old Jun 12th, 2008, 6:38 pm
Veteran
 
Join Date: Jun 2006
Location: , ,
Posts: 2,680
It appears the Kisan Tail Blazers aren't quite ready for prime time with the BMW Canbus?

Mack
GMack is offline  
post #7 of 11 (permalink) Old Jun 12th, 2008, 6:46 pm
Rookie
 
Join Date: May 2008
Location: Bloomington, IN, USA
Posts: 41
Question Kisan

Just ordered the pair... anyone know if they accept returns if used??
roadkingedout is offline  
post #8 of 11 (permalink) Old Jun 12th, 2008, 9:21 pm
Member
 
mikec's Avatar
 
Join Date: Jan 2007
Location: High Point, NC, USA
Posts: 106
Quote:
Originally Posted by roadkingedout
Just ordered the pair... anyone know if they accept returns if used??
They don't accept returns for cash. Call their customer service and tell them about the problem. They'll send you another set, just like they did for me.

Mike
mikec is offline  
post #9 of 11 (permalink) Old Jun 13th, 2008, 9:50 am Thread Starter
 
Join Date: Jun 2008
Posts: 468
Quote:
Originally Posted by mikec
They don't accept returns for cash. Call their customer service and tell them about the problem. They'll send you another set, just like they did for me.

Mike

Are the second set any better?
iflybricks is offline  
post #10 of 11 (permalink) Old Jun 13th, 2008, 3:07 pm
Rookie
 
Join Date: May 2008
Location: Bloomington, IN, USA
Posts: 41
Question Kisan

ditto: how is the 2nd set?????
roadkingedout is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
No More Baboon Ass! The Wunderlich Triton 2 K1200S Tail Light Pirate Accessories 6 Jun 17th, 2009 9:02 pm
Vario levers and Triton2 tail light install...... 2tall2fall K12/1300R/R-Sport 17 Dec 16th, 2006 1:51 pm
tail light assembly mods chuckheinch K12/1300R/R-Sport 5 Mar 31st, 2006 8:46 pm
red tail light bulb ssls6 K1200RS/GT (Classic) 9 Dec 14th, 2005 9:33 pm
New LED Tail Light for the K1200S KPower K12/1300S 30 Nov 14th, 2005 9:00 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome