GS911 and brake fault indicator reset? - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old Sep 1st, 2008, 8:59 pm Thread Starter
Addict
 
Join Date: May 2007
Location: , ,
Posts: 646
GS911 and brake fault indicator reset?

Guys-

Tonight my GT turned 15k, and almost IMMEDIATELY my brake fault indicator came on. Presuming it was a 15k "trigger" for brake pad maintenance, I ignored it. I was nearly at my destination, and after being parked a couple hours, I went to start the bike, and low and behold, not only was the brake fault indicator still glowing, but the low-beam light didn't come on, complete with the appropriate fault indicator for that too.

I left to go home with my high-beam on, and less than a block away, my low-beam came on and stayed on for the 30 minute highway ride. However, the brake fault indicator WENT OUT, but came on again when I exitedthe freeway using the brakes and it remains on.

I immediately hooked up my GS-911 and it ONLY READ THE LOW-BEAM FAULT. It NOWHERE wants to read the continuing brake fault code! I cleared the low-beam fault, and the low-beam appears to still be working.

1. Why the #%$#$% doesn't that GS-911 read the brake fault, and more importantly, allow me to CLEAR IT? That's whyI invested in the thing to begin with, thinking (HOPING) that would be the only routine fault it would ever need to clear!

2. Has anyone experienced multple electrical faults at once like this?

I have to say, if I can't get a reason why that GS-911 DOES NOT read the brake fault, I am gonna be PISSED.

Thanks-

B.
Brahma is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old Sep 1st, 2008, 9:52 pm Thread Starter
Addict
 
Join Date: May 2007
Location: , ,
Posts: 646
Grif- Any experience resetting ABS fault codes with the GS-911?
Brahma is offline  
post #3 of 8 (permalink) Old Sep 1st, 2008, 10:17 pm
Veteran
 
Join Date: Jun 2006
Location: , ,
Posts: 2,680
That's a question I asked some time ago since I haven't had the privilege of that light coming on yet.

Have you contacted Stephan Thiel at www.hexcode.co.za ? He may know the ifs and whys. I have their latest beta installed (GS-911-Beta-807.5) and they added some ABS stuff to it. One thing I learned about these BMW's on their forum is that the stored codes can mysteriously disappear. Then again, my car did the same thing whenever the battery crapped out too - or I did it intentionally to buffalo the smog check guy.

Good luck!


Mack
GMack is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old Sep 1st, 2008, 11:41 pm
Strafist
 
grifscoots's Avatar
 
Join Date: Aug 2006
Location: Outside New Braunfels, TX, USA
Posts: 2,544
Quote:
Originally Posted by Brahma
Grif- Any experience resetting ABS fault codes with the GS-911?
I'm thinking he has an intermittent on a wire to his brake pads that's throwing the fault. IIRC, the new beta will reset, but it won't do any good if there's a physical problem that isn't corrected first.

-=grif=-
What was that middle thang?
grifscoots is offline  
post #5 of 8 (permalink) Old Sep 2nd, 2008, 4:52 am Thread Starter
Addict
 
Join Date: May 2007
Location: , ,
Posts: 646
I contacted GS-911 and haven't checked for a message yet. I understand that I can't reset a recurring problem, but the issue is the light is ON and the GS-911 is NOT seeing any fault. If you say it can reset the "normal" brake fault indication, then something is up that can be attended to.

Odd that my headlight went off at the same time too eh?
Brahma is offline  
post #6 of 8 (permalink) Old Sep 2nd, 2008, 4:58 am Thread Starter
Addict
 
Join Date: May 2007
Location: , ,
Posts: 646
Got the response... note that the GS-911 does not see the brake indicator fault, but the explanation makes perfect sense. Thanks to Stephan for incredible and fast product support- the GS-911 has my endorsement!

Also- can we confirm what Stephan says about "automatically resetting" the indicator lights?

---

Stephan-



Sorry about the "caps", just trying to clarify the situation so nothing gets lost in translation.



Yes! I'd love to be in the BETA program! I really do love the GS-911 and use it one my R1200GS as well! Yes! I'd love it to at least "tell" me it sees the issue!



I'll get you a pic later today...



Thanks for the quick response!



DSD

> Subject: [issue510] GS-911 NOT reading 2006 BMW K1200GT Brake Fault- what's up with THAT?
>
> From: [email protected]
> Date: Tue, 2 Sep 2008 05:02:03 +0000
>
>
> Stephan Thiel added the comment:
>
> hi,
>
> As a favor to us, pls try and refrain from using capital letters too
> much - it give emails a somewhat threatening "tone", which I'm sure is
> not the way you intended the email.
>
> Now, to the matter at hand. The brake pad wear indicator coming on, is
> not a fault - thus there are no fault codes logged for that - resetting
> the brakepad wear indicator is a completely separate function in the ZFE
> controller - this, much like the Service interval reminders, is a future
> function that we are currently working on.
>
> If you could do me a second favor, and send me a couple of photos of the
> instrument cluster with the indicator showing, I can set up a related FAQ.
>
> Also, I will be adding you to the K-breakpadwear test group for the time
> being - meaning you will be one of the customers notified when we have
> this functionality in test, then you can be one of the first to test it
> - if you wish (for interest: I've already got this functionality figured
> out to the T, but we still need to implement it in a public Beta (a
> couple of other prerequisites precede this implementation)
>
> Also, as far as I'm aware, as of the March 08 (i think CD23) software,
> the the ZFE automatically resets this indicator after the successful
> replacements of the brake pads.
>
> best,
> Stephan
>
--------------------
> >
> > Hi-
> >
> > I've had my GS-911 for about a year and it has been relatvely handy.
> > I bought it primarily to be able to reset brake faults on my '06
> > K1200GT when it was time to change the pads and they generate a
> > warning- hopefully NOT that the bike would have other issues that
> > needed looking at...
> >
> > Tonight, atr 15,000 mles, my brake fault indcator came on for the
> > first time, and the GS-911 SEES NOTHING. What is up with THAT?
> >
> > I am using the current 'beta' build of the software, which apparently
> > updated the firmware og the GS-911 itself.
> >
> > In ANY EVENT, the fault code SHOULD BE visible to the unit, which is
> > why I invested in it.
> >
> > Can I please get an explanation about WHY the GS-911 DOES NOT see the
> > fault?
> >
> > Thank you-
> >
Brahma is offline  
post #7 of 8 (permalink) Old Sep 2nd, 2008, 1:10 pm
Would rather be riding
 
bonafidebob's Avatar
 
Join Date: Sep 2007
Location: Mountain View, CA, USA
Posts: 537
Quote:
Originally Posted by Brahma
Tonight my GT turned 15k, and almost IMMEDIATELY my brake fault indicator came on. Presuming it was a 15k "trigger" for brake pad maintenance, I ignored it.
Mine recently came on too, at about 13K. I inspected all the pads and they all looked like they had plenty of life left to me. I don't have a GS911, but the bike went to the dealer for the 12K service today and they'll checking it all out.

Have you had the "broken wire" brake pad fault already? I did, at about 1K miles, fixed at the dealer by replacing the wires to the front indicator. A broken wire would explain your intermittent problem I think.
bonafidebob is offline  
post #8 of 8 (permalink) Old Sep 2nd, 2008, 3:32 pm
Senior Member
 
Join Date: Mar 2007
Location: North Coast, OH, USA
Posts: 129
like Mr. Thiel mentioned, the broken wire fault and subsequent idiot light on the dash are not clearable with the GS911. I had the fault at 3600mi. and tried to clear it w/the GS911 to no avail....had to go to the dealer for clearing.


F

05LT
07GT
Florian is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome