Escort Passport 9500i - K-Bikes.com - Excellence in Motion
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old Feb 5th, 2009, 2:49 pm Thread Starter
Noob
 
JeffBohl's Avatar
 
Join Date: Dec 2008
Location: Tomball, TX, USA
Posts: 26
Escort Passport 9500i

My Escort 9500i Radar Detector gives repeated laser alerts when I use it on my 2007 K1200Gt. Works good in the car so I called Escort and they tell me that it is electronic interference. I can send it to them and they can turn down the sensitivity but then it won't pick up real laser alerts as well. Has anyone else experienced this? Escort says that a new one will probably do the same thing. Does anyone have other brands that work okay on their K1200GT's ??? Not sure if I want to get it turned down since then it would not work as well in the car. Any advise is appreciated.

Jeff
JeffBohl is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old Feb 5th, 2009, 3:02 pm
IBR# 366
 
Meese's Avatar
 
Join Date: Apr 2007
Location: Oxnard, CA, USA
Posts: 3,140
My V1 will sometimes trigger as a laser alert if the input voltage drops too low, like when starting the bike, or running full aux lights and heated gear and braking down to near idle. And it will occasionally trigger from some of the newer GM LED brake lights, but not very often. It is also possible to get a trigger when riding directly into a setting sun, but that takes a very specific set of conditions.

You could try an inline power filter to see if it's that sort of interference, or possibly move the detector to a different location (away from a gps or intercom, for example).

There is also a theory that laser detection is useless, as once they've got you targeted you're already caught. So some guys turn it off entirely to avoid any false alerts.

In my case, it has alerted me to a valid laser hit twice, and I was able to, um, modify my driving style so as to not get pulled over. But those are pretty rare cases.

Ken
Pacific NorthWet
'13 Dark Graphite Metallic K16GTLD, 24K miles and counting...
'09 Magnesium Beige Metallic K13GT, 60K miles miles and counting...
'02 Mauve Metallic K12LTC, 106K miles and sold
BMWLT#145, IBA# 366, MOA# 111996, SCMA# 24032

All lower 48 states plus Alaska on the K13GT in two weeks . . .

Some people see the gas tank as half empty. Some see it as half full. All I care is that I know where the next tankful is coming from...
Meese is offline  
post #3 of 11 (permalink) Old Feb 5th, 2009, 3:37 pm
Veteran
 
Join Date: Jun 2006
Location: , ,
Posts: 2,680
The only problem I had with my 9550i on the GT was it interfered with XM Radio (wouldn't get channels). Escort did something to it and it worked (it was under warranty). Sometimes I can get an occasional LED brake light to set of the laser side of it as well as some sunset conditions for whatever reason.

I recently had it converted to the 9500ix upgrade and it's great! No problems and the ability to update the weekly speed and red light cams and TrueLock work well. Very quiet in the city which is a blessing. Voice and tones work well through the Autocom (with their standard ground loop cord which seems to be needed for everything bike-powered to the Autocom.

I like it so much I bought another 9500ix for the car. The upgraded one I sent in to them has the red display which is easier to use in the daylight on the bike, also came with a 3 year database subscription and a spare auto cord. Blue display of the new one is better in the car.


Mack
GMack is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old Feb 5th, 2009, 4:36 pm
Rookie
 
pjgerstenberger's Avatar
 
Join Date: Jun 2007
Location: Ft Lauderdale, fl, usa
Posts: 42
I have a 9500I and the exact same problem. I allowed them to do the mod to the laser circut. No more falsing. The funny thing was, my 7 year old 8500 suddenly started doing the EXACT same thing. Called Escort, they said, the filters get old, and this can happen.
Buy a new one. So I did. Had the exact same problem Something changed on the bike,
I don't know what. Also, the new 9500 I has a horrible problem with alternator noise.
Either through ear buds or the Autocom. 8500 never had that problem. I had to sent the
9500 back in last week because the audio failed. Would not make a sound, either through the ear buds, or the internal speaker. I asked them to l;ook at the alternato noise problem.
The only response was we'll sent the repair people an e-mail about it.
The GPS trick is pretty cool though. It really works well.
pjgerstenberger is offline  
post #5 of 11 (permalink) Old Feb 5th, 2009, 5:43 pm Thread Starter
Noob
 
JeffBohl's Avatar
 
Join Date: Dec 2008
Location: Tomball, TX, USA
Posts: 26
I have been reading a few other posts that were already here before I started my thread and now am learning a lot. Thanks guys for your response. I have to decide if i am going to send this one in or just use it in the car and get another one. It works really well in the car and in fact just saved me a few minutes ago. I like the idea of sending it in for an upgrade to the 9500ix and might do that......hmmmmmmmm decisions decisions but one thing is for sure..... the laser alerts every few minutes will not do when it is on the GT. I have to do something.

Jeff
JeffBohl is offline  
post #6 of 11 (permalink) Old Feb 5th, 2009, 6:03 pm
Enthusiast
 
Join Date: Nov 2006
Location: Boulder, CO, USA
Posts: 376
I have used my 9500i on both GT's (07 & 08) with no problems at all. It's powered through the CanBus Helper and also is hooked up to a Screamer (120db alert horn). It has saved me untold # of times and has paid for itself many times over. Although I would probably not get another one as I do not find the GPS feature very usefull.

And those who were seen dancing were thought to be insane by those who could not hear the music.
DavidS is offline  
post #7 of 11 (permalink) Old Feb 5th, 2009, 6:34 pm
Veteran
 
Join Date: Jun 2003
Location: Lawrenceville, NJ, USA
Posts: 896
FWIW I found that Infiniti cars always set off my Valentines Laser alert..
Erik is offline  
post #8 of 11 (permalink) Old Feb 5th, 2009, 7:20 pm
Enthusiast
 
rebeltown's Avatar
 
Join Date: Jun 2008
Location: , NJ, USA
Posts: 233
I don't have an Escort but my Bel will give me some falsies if the unit is plugged into the cigar lighter socket that is wired to the accessory plug in front of the battery which is CanBus controlled but will not alarm falsely if used on batteries only. Go figure...

Gary
2007 K1200GT
Dark Graphite Grey
New Jersey-Don't Laugh!
rebeltown is offline  
post #9 of 11 (permalink) Old Feb 5th, 2009, 9:05 pm
Addict
 
dwsdad's Avatar
 
Join Date: Jul 2004
Location: Marshall, TX, USA
Posts: 549
My Escort 8500 gives false laser alarms at time too. Oddly enough, it seems I get the laser alerts about the same time my phone is searching for a cell tower. Ever notice how those nasty AT&T GSM phones make a noise through speakers every once and a while? One of 2 things is happening. You're either about to get a phone call or it's looking for a signal. And there are some stretches of roads I travel where I'll hear that stupid buzz of the phone and my laser indicator is flashing on my 8500. Weird.

Doug Turner
'86 Concours
'99 K1200LT - gone
'06 K1200GT - the new kid in town
'08 Wing - gone
Marshall, TX
dwsdad is offline  
post #10 of 11 (permalink) Old Feb 6th, 2009, 6:54 am
Rookie
 
pjgerstenberger's Avatar
 
Join Date: Jun 2007
Location: Ft Lauderdale, fl, usa
Posts: 42
I find the truelock GPS feature of the 9500I very useful. I live in the Tampa area and work in Ft Lauderdale. I traverse the same 230 mile stretch of the state twice a week.
15 miles is interstate, the rest is back roads. In and out of 6 towns, with about 11 known K band hotspots, all of which are currently blocked. When it goes off, I'm haulin' it in. For my purposes, it works like a charm.
pjgerstenberger is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Escort 9500ix GMack Radar Detector 15 Oct 17th, 2008 12:27 pm
Mounting an Escort MassGT Radar Detector 33 Jan 5th, 2008 7:01 pm
Escort 9500i, got me one.. ldbikin Radar Detector 6 Jun 6th, 2007 10:11 pm
Escort 8500x50 red for $239, blue $279 StevieVVet Radar Detector 0 Aug 7th, 2006 6:23 pm
Passport Papilio Humor 1 Jan 31st, 2006 11:40 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome