Finally, High Idle experienced !! - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Mar 24th, 2009, 11:03 am Thread Starter
Member
 
Andre's Avatar
 
Join Date: Jun 2006
Location: Brussels, , BELGIUM
Posts: 100
Finally, High Idle experienced !!

Guys, I'm glad to announce that I finally (after 30.000 miles) had the honours to experience the "high idle" thing.
I went for a long ride, then when I closed the throttle, well you know ..
Went to the shop. They ordered the airbox and will fix it beginning next week.
Funny that it finally occurred. On the 15th I will ride the K13. vengeance of the abandoned bike ?
Andre is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Mar 24th, 2009, 11:16 am
 
Join Date: Jun 2008
Posts: 468
Quote:
Originally Posted by Andre
Guys, I'm glad to announce that I finally (after 30.000 miles) had the honours to experience the "high idle" thing.
I went for a long ride, then when I closed the throttle, well you know ..
Went to the shop. They ordered the airbox and will fix it beginning next week.
Funny that it finally occurred. On the 15th I will ride the K13. vengeance of the abandoned bike ?
What year is your bike. Is it in the mix of air box problems and you've just never had your's replaced or is it a newer bike? Thought that had that sorted out into 2008 builds.
iflybricks is offline  
post #3 of 5 (permalink) Old Mar 24th, 2009, 2:44 pm Thread Starter
Member
 
Andre's Avatar
 
Join Date: Jun 2006
Location: Brussels, , BELGIUM
Posts: 100
details

It's on 07GT delivered in november 06 , and still running the original airbox and all.
Andre
Andre is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old Mar 24th, 2009, 3:08 pm
 
Join Date: Jun 2008
Posts: 468
Quote:
Originally Posted by Andre
It's on 07GT delivered in november 06 , and still running the original airbox and all.
Andre
Okay,I believe this is one of the bikes still affected by these problems. How come you didn't get it fixed at any service? I thought they were doing all of them or only if you had symptoms. thanks!
iflybricks is offline  
post #5 of 5 (permalink) Old Mar 24th, 2009, 10:03 pm
Addict-oholic
 
larrykay's Avatar
 
Join Date: Jun 2003
Location: New Rochelle , NY, USA
Posts: 1,407
Quote:
Originally Posted by iflybricks
Okay,I believe this is one of the bikes still affected by these problems. How come you didn't get it fixed at any service? I thought they were doing all of them or only if you had symptoms. thanks!
ONLY, if they have symptoms. Not a recall, just a minor technical bulletin !!!

Larry
Deep Blue 2009 K1300GT
larrykay is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Absolutely the most detailed description of the K1200S I've come across... sinc K12/1300S 20 Jul 19th, 2014 10:04 am
High Idle: My Observations ncooper K12/1300GT (Next Gen) 86 May 29th, 2009 5:11 pm
Update on high idle with new air box BobD K12/1300GT (Next Gen) 8 Jan 31st, 2008 6:19 pm
High Idle vs. Break In method? GT-1 K12/1300GT (Next Gen) 6 Oct 9th, 2007 12:12 pm
High idle BBS in Australia BobD K12/1300GT (Next Gen) 2 Jun 26th, 2007 4:52 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome