Still stalling after a ride...anyone else? - K-Bikes.com - Excellence in Motion
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 32 (permalink) Old Mar 26th, 2009, 8:45 pm Thread Starter
 
Join Date: Jul 2008
Posts: 4
Unhappy Still stalling after a ride...anyone else?

I thought I had fixed the problem, but apparently not...
Is anyone else still experiencing a stalling problem with their K1200GTs? I replaced the oxygen sensor earlier, and my problem seemed to have gone away. Then recently, after a short ride of 20 or so miles, I came up to a stop, pulled the clutch to start downshifting and the rpm's dropped to zero and the bike went dead. It took a couple of tries, but the bike restarted. Any help out there?
Sgfatc is offline  
Sponsored Links
Advertisement
 
post #2 of 32 (permalink) Old Mar 26th, 2009, 9:32 pm
Veteran
 
Join Date: Jun 2006
Location: , ,
Posts: 2,680
Airbox?


Mack
GMack is offline  
post #3 of 32 (permalink) Old Mar 26th, 2009, 9:43 pm
Veteran
 
Robert_W's Avatar
 
Join Date: May 2007
Location: Troy, MT, USA
Posts: 1,658
Yeah, airbox? What year bike? Does it happen a lot? Every once in a blue moon my bike will want to drop rpms after riding for a while even with the new air box. However a quick blip of the throttle has always taken care of it without stalling.

'07 GT Sold- 2012 GSA Triple Black - Farkles O'Plenty!

I think I'm diagonally parked in a parallel universe....but I am NOT a Dental Floss Tycoon!
What's with this STUPID Cosmic Door?! ....Going Somewhere?!....Going Somewhere?!


Robert_W is offline  
Sponsored Links
Advertisement
 
post #4 of 32 (permalink) Old Mar 26th, 2009, 10:53 pm
Strafist
 
grifscoots's Avatar
 
Join Date: Aug 2006
Location: Outside New Braunfels, TX, USA
Posts: 2,544
Do you get a whooshing sound when you open the gas cap? If so, clogged charcoal cannister.'

I haven't heard of it happening on these bikes, yet, but it will.

-=grif=-
What was that middle thang?
grifscoots is offline  
post #5 of 32 (permalink) Old Mar 27th, 2009, 11:49 am Thread Starter
 
Join Date: Jul 2008
Posts: 4
Question Still stalling...

My GT is an '07, and the airbox was replaced, along with receiving the latest software. I put in the new oxygen sensor when nothing else seemed to work. I haven't done the charcoal canister yet...where is it and is it difficult to do? The bike is still under warranty. Should the dealer attempt to deal with this issue. Thanks to everyone for their replys!
Sgfatc is offline  
post #6 of 32 (permalink) Old Mar 27th, 2009, 12:19 pm
IBR# 366
 
Meese's Avatar
 
Join Date: Apr 2007
Location: Oxnard, CA, USA
Posts: 3,140
Mine stalls on ocassion, too. '07 with new airbox, new O2 sensor, canister in place, and a lot of miles. It's annoying, but the bike always starts right back up.

What's more annoying is the hesitation/throttle lag that hits when rolling on power coming out of a corner. Apparently, the only real fix for that is a K13GT.

Ken
Pacific NorthWet
'13 Dark Graphite Metallic K16GTLD, 24K miles and counting...
'09 Magnesium Beige Metallic K13GT, 60K miles miles and counting...
'02 Mauve Metallic K12LTC, 106K miles and sold
BMWLT#145, IBA# 366, MOA# 111996, SCMA# 24032

All lower 48 states plus Alaska on the K13GT in two weeks . . .

Some people see the gas tank as half empty. Some see it as half full. All I care is that I know where the next tankful is coming from...

Last edited by Meese; Mar 28th, 2009 at 1:20 pm.
Meese is offline  
post #7 of 32 (permalink) Old Mar 27th, 2009, 1:38 pm
Member
 
Join Date: Jun 2006
Location: , ,
Posts: 77
I had the stalling problem - and it got really bad. The dealership replaced the crankshaft sensor and that solved about 90% of the stalls.

2007 K1200GT
IBA#31809
JWILLIS125911 is offline  
post #8 of 32 (permalink) Old Mar 27th, 2009, 4:43 pm
Veteran
 
Join Date: Jun 2003
Location: Lawrenceville, NJ, USA
Posts: 896
If it's under warrenty, and it does it more than once in a blue moon then I would for sure hold the dealers feet to the fire to have them get it right.The warrenty is part of the (large) cost of these bikes, no way should you be doing BMW's work to make the bike run right.
Erik is offline  
post #9 of 32 (permalink) Old Mar 27th, 2009, 5:44 pm
Strafist
 
grifscoots's Avatar
 
Join Date: Aug 2006
Location: Outside New Braunfels, TX, USA
Posts: 2,544
Quote:
Originally Posted by Sgfatc
I put in the new oxygen sensor when nothing else seemed to work. I haven't done the charcoal canister yet...where is it and is it difficult to do?
It's under the gas tank on the left side and real easy to do.

-=grif=-
What was that middle thang?
grifscoots is offline  
post #10 of 32 (permalink) Old Mar 27th, 2009, 5:45 pm
Strafist
 
grifscoots's Avatar
 
Join Date: Aug 2006
Location: Outside New Braunfels, TX, USA
Posts: 2,544
Quote:
Originally Posted by Meese
What's more annoying is the hesitation/throttle lag that hits when rolling on power coming out of a corner. Apparently, the only real fix for thay is a K13GT.
So far, the PowerFrk is still working with absolutely no hesitation. I'm just waiting for hot weather to declare it a success. Only been up to 85 degrees here.

-=grif=-
What was that middle thang?
grifscoots is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
A ride tale Arr2Kay Bike Talk 8 Dec 1st, 2010 3:42 am
Bike stalling after long ride pdamski K12/1300GT (Next Gen) 44 Jan 24th, 2009 10:06 am
The First Ride.. K1200GT.. Goin' to da Dark Side! MarkMGT K12/1300GT (Next Gen) 17 Aug 18th, 2008 7:35 am
Two-pass ride Sept. 3rd Razel Ride Tales 0 Sep 4th, 2006 8:35 pm
long story about last years ride KbikeLarry Ride Tales 0 Jun 27th, 2006 11:14 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome