Reset on brake pad wear indicator - K-Bikes.com - Excellence in Motion
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old Mar 27th, 2009, 2:32 pm Thread Starter
Veteran
 
GillyWI's Avatar
 
Join Date: Jul 2008
Location: Evansville, WI,
Posts: 1,256
Reset on brake pad wear indicator

I have what the dealer thinks is a case of "wire ties way too tight" and they sent me a "set" of front pads (actually just for the right caliper). I replaced them and still have the light (I also tried plugging the pad sensor into the rear connector and the light was still on), so is there a way to reset the light, as the dealer suggested by disconnecting the battery, or is the computer necessary to reset the light? Assuming I don't want to invest in my own computer right now to reset it, I know you can buy a device to do this at home.

Gilly
GillyWI is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old Mar 27th, 2009, 6:37 pm
Veteran
 
Join Date: Jun 2006
Location: , ,
Posts: 2,680
I don't know if the GS-911 will reset that light yet. It was one of the reasons I bought it, but it (the GS-911) seems to have missed that portion.

Supposedly, they are to address it soon. Probably when they can charge everyone for the update who has already bought it thinking it could do a reset.

Mack
GMack is offline  
post #3 of 13 (permalink) Old Mar 27th, 2009, 7:14 pm Thread Starter
Veteran
 
GillyWI's Avatar
 
Join Date: Jul 2008
Location: Evansville, WI,
Posts: 1,256
The more threads I read on this, the more I wonder if it actually CAN be reset. In other words, did the pad/sensor even NEED to be replaced? I read about possibly the harness might be pinched in the area behind the tupperware, maybe not on the fork leg area? It sounds like if this is the problem, the light should go out almost immediately after replacing the pad? Kind of a bummer because I had that tupperware off this winter for a repaint (problem existed before the tupperware was removed, although now I wonder if it came on sometime after my tip-over)
Gilly
GillyWI is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old Mar 28th, 2009, 12:37 pm
IBR# 366
 
Meese's Avatar
 
Join Date: Apr 2007
Location: Oxnard, CA, USA
Posts: 3,140
Usually, it is the wire section attached to the brake pads that gets damaged, but a break anywhere in the circuit can cause the light to come on. It's just a simple continuity check after all.

The early BMW software would not reset the brake warning light after the wire was replaced, and the original GS-911 didn't have that capability either. So that meant a dealer visit to hook the bike up to their shop computer.

The newest BMW bike software (v.11 or v.12) will reset the brake warning light when the wire is replaced, and the newest GS-911 software will allow you to reset it, too. The dealer may well charge you for a software upgrade, but I believe the GS-911 upgrade is free.

Again, another reason I should have dropped in at Grif's a few days ago . . .

Ken
Pacific NorthWet
'13 Dark Graphite Metallic K16GTLD, 24K miles and counting...
'09 Magnesium Beige Metallic K13GT, 60K miles miles and counting...
'02 Mauve Metallic K12LTC, 106K miles and sold
BMWLT#145, IBA# 366, MOA# 111996, SCMA# 24032

All lower 48 states plus Alaska on the K13GT in two weeks . . .

Some people see the gas tank as half empty. Some see it as half full. All I care is that I know where the next tankful is coming from...
Meese is offline  
post #5 of 13 (permalink) Old Mar 28th, 2009, 12:42 pm
Noob
 
gtcharlie's Avatar
 
Join Date: Mar 2009
Location: Roswell, GA, USA
Posts: 12
test
gtcharlie is offline  
post #6 of 13 (permalink) Old Mar 28th, 2009, 8:01 pm Thread Starter
Veteran
 
GillyWI's Avatar
 
Join Date: Jul 2008
Location: Evansville, WI,
Posts: 1,256
Is there some test mode I can get in to to find out what version I have? Otherwise, if anyone can advise, it was built around March of 07.
Makes sense that it needs to be reset.
I wonder if they can just do a flash update on just the cluster, I am hesitant to have the BMS-K updated, I like the way it growls.
Am tempted to just install a jumper in the pad sensor sockets and forget this nonsense, once I get the light out.
Gilly
GillyWI is offline  
post #7 of 13 (permalink) Old Mar 28th, 2009, 10:49 pm
Strafist
 
grifscoots's Avatar
 
Join Date: Aug 2006
Location: Outside New Braunfels, TX, USA
Posts: 2,544
Quote:
Originally Posted by GillyWI
Is there some test mode I can get in to to find out what version I have? Gilly
Hey Gilly, go on www.bmwlt.com and look for a thread on GS-911 owners that we've compiled of folks who own them. I bet there is someone near you. The GS-911 will give you the software version.

-=grif=-
What was that middle thang?
grifscoots is offline  
post #8 of 13 (permalink) Old Jun 12th, 2009, 9:33 pm Thread Starter
Veteran
 
GillyWI's Avatar
 
Join Date: Jul 2008
Location: Evansville, WI,
Posts: 1,256
Another post due to the dealer visit I paid today (see other thread about no-start problem). They reset the light, I went to leave and the odo/trip meters still reading "MLS" instead of "MI", I heard this would change when the update was done.
OK, so service manager says he didn't have him do the IC update. Reason was; I had told him if there is still a problem with the pad warning harness (besides the wiring on the pad sensor), DON'T rip the bike apart, I won't have time to take a loaner bike and get that back once my bike is done (I brought my bike in at about 4pm). So the tech says that they have had problems with that dowload and one time it took 4 hours to get the bike to run again!
I had replaced the front pads, but without that download, the pad warning light won't reset itself. Evidently the pad warning harness was the culprit, as the pad warning light is staying off at this time.
Gilly
GillyWI is offline  
post #9 of 13 (permalink) Old Jun 13th, 2009, 5:06 am
Senior Member
 
Alpinebiker's Avatar
 
Join Date: Jul 2008
Location: , 01, France
Posts: 164
Ive had the pinched wire warning light problem 3 times. Last time without telling me, the dealer just cut the cable so the light wouldn't come on again!!!!! Didn't bother telling me, and only found it when cleaning the bike.

I complained and was told that the cable is a one piece item only available with the pads, so if you want the light fixed it'll cost 85 one side or 95 the other. Of course no-one replaces one side only so cost would be 220 to have your warning light fixed!

Seems no-one at BMW thought of this problem and so you can't buy a cheap cable, but have to replace pads that might not need replacing, or keep looking at a warning light, which comes on 1000's of kms too soon anyway. Frankly the whole thing is a pain, better to check the pads yourself than wait for an idiot light!
Alpinebiker is offline  
post #10 of 13 (permalink) Old Jun 13th, 2009, 7:57 pm Thread Starter
Veteran
 
GillyWI's Avatar
 
Join Date: Jul 2008
Location: Evansville, WI,
Posts: 1,256
They can't just cut the cable. They'd need to splice the 2 wires together at some point. Once there is an open in the circuit (which is what cutting the wires would do), the light comes on.
I have thought of doing the splice together though, I wouldn't be the first.
Gilly
GillyWI is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Singing front brake SydneyGuy K12/1300R/R-Sport 70 Jan 3rd, 2009 9:49 pm
Brake Pad Wear Indicator Fergie K12/1300GT (Next Gen) 33 Nov 9th, 2008 8:42 am
Brake Pad Wear Indicator chuckwilmot K12/1300GT (Next Gen) 31 Oct 7th, 2008 5:02 am
Brake Pad Wear Indicator Fergie K12/1300GT (Next Gen) 1 Sep 26th, 2008 2:47 pm
GS911 and brake fault indicator reset? Brahma K12/1300GT (Next Gen) 7 Sep 2nd, 2008 3:32 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome