BoosterPlug Question - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Feb 20th, 2010, 12:01 pm Thread Starter
cwf
Noob
 
Join Date: May 2009
Location: Crestwood, KY, USA
Posts: 16
BoosterPlug Question

I have a 2006 K1200GT I purchased in May of last year so this is the first time I've ridden it in cold weather. I recently installed a "Boosterplug" and today (41 deg F) is the first day I've been able to ride since the install.

I bought the Boosterplug because (last summer in warm to hot weather) I was getting some MILD slow speed surge and an infrequent flat spot at 3K rpm. For example when riding on the freeway at 70mph and you craked the throttle it would bog down for a second before taking off....although it was an infrequent issue.

I must say I'm disappointed with the boosterplug at this point. I rode about 10 miles and the bike seems fine until I get up to 4 or 5K rpm but then doesn't seem to have good power under full throttle. It acts as if it's running rich...better power delivery if I only give it half throttle. Before the boosterplug....when I cracked the throttle it was all smiles.

I did disconnect the battery for about an hour during the install and after reassembly I reset the TPS by turning on the key and opening and closing the throttle three times.

Question to the group is - do I need to wait and ride it some more to let the ECU re-learn its fuel map before jumping to conclusions? I wish there was a way to install a switch so that I could take it out of the circuit without two hours of tupperware fondling.

Any advice (well constructive advice) is welcome and appreciated.
cwf is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Feb 20th, 2010, 7:13 pm Thread Starter
cwf
Noob
 
Join Date: May 2009
Location: Crestwood, KY, USA
Posts: 16
I may have answered my own question. After lettting the bike sit for a while I reset the TPS again and went for another 10 mile ride. Bike ran like I remembered. My theory is that the ECU had defaulted to rich and it had to relearn the conditions. Seems to run well now I can't wait to see if in warmer weather the bike has the low speed surge it used to have.
cwf is offline  
post #3 of 5 (permalink) Old Feb 20th, 2010, 10:21 pm
Enthusiast
 
jpel's Avatar
 
Join Date: Jun 2003
Location: Baltimore, MD, USA
Posts: 284
Please update us after a few more rides. I'm interested in the boosterplug and am waiting to see how it pans out for those who have installed one. I currently have an FRK installed and the performance is superb except for the low rpm/low gear lean surging. This is what I am interested in getting rid of while keeping the excellent performance everywhere else.
Thanks!

Jim
jpel is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old Mar 7th, 2010, 5:50 pm Thread Starter
cwf
Noob
 
Join Date: May 2009
Location: Crestwood, KY, USA
Posts: 16
Now that I've ridden a few miles with the boosterplug I'm satisfied it works as advertised. No slow speed jerky throttle and no hesitation at all. Will need to wait until summer temps are here before pronouncing that the thing is great.

Rode for about 20 miles today with a friend who drives a Honda VFR800,,,,I'm about 80 pounds
heavier than he is and he could not keep up.
cwf is offline  
post #5 of 5 (permalink) Old Mar 7th, 2010, 9:13 pm
Rookie
 
ccroach's Avatar
 
Join Date: Jul 2008
Location: Sioux Falls, SD, USA
Posts: 35
I just installed my boosterplug a few days ago and I'm very happy with the results. No more flat spots or low speed surging. The bike runs like it should have from the factory now. We'll see how it works when the 90-100 + days with high humidity get here, but so far it's working great for me. (by the way I'm in southern Louisiana, so it'll be hot soon enough)

Michael
"How long am I going to be dead ?"
2007 K1200S
ccroach is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Pump Question Andy_K100 Other K-Bikes Discussion 10 Jan 12th, 2009 4:37 pm
Avon storm size question KGK1200GT K12/1300GT (Next Gen) 2 Apr 9th, 2008 9:21 am
A newbie question MrChrome K12/1300R/R-Sport 15 Jul 26th, 2007 5:16 pm
Garmin Routing Question 02k12rs GPS 4 Nov 17th, 2006 4:45 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome