SW update works - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Nov 15th, 2010, 7:06 pm Thread Starter
DrD
Member
 
DrD's Avatar
 
Join Date: Nov 2008
Location: Reston, VA, USA
Posts: 110
Smile SW update works

This past Saturday I took my '08 K1200GT (with just shy of 8,000 miles) in for service. I complained about slow throttle response and roughness in the 3,500 to 4,800 RPM range. The shop guy told me there was a SW upgrade to address that.

He was right. The 80+ miles back, then more riding Sunday and Monday have convinced me that the issues in that RPM range are gone. Heck, even gentle engine braking now works smooth as compared to jerkiness that happened before.

I don't know the update number. The last time I had my bike in the shop was a year ago, so sometime during the last year there has been a change for the good in the SW.

When in doubt, apply more throttle.
2008 K1200GT, Dark Graphite, "#4, the Dancing Hippo"
DrD is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Software update cuts power from canbus? phollywood K12/1300GT (Next Gen) 21 Nov 23rd, 2008 10:21 pm
BRAKE ! LED Fails After Software Update panhard K12/1300R/R-Sport 0 Jul 20th, 2008 4:09 pm
Pipenslippers post crash update pipenslippers K12/1300GT (Next Gen) 5 Sep 6th, 2006 4:20 am
CIP CD 6.0 Update eljeffe K12/1300S 10 Apr 23rd, 2006 6:55 pm
Software update glitch? wyeknott K12/1300S 21 Nov 18th, 2005 1:44 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome