Ok To Use Old Gear Oil?? - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Mar 11th, 2011, 4:51 pm Thread Starter
Veteran
 
Join Date: Jun 2003
Location: Lawrenceville, NJ, USA
Posts: 896
Ok To Use Old Gear Oil??

I have most of a quart of Amsoil Severe Gear 75W-90 left from when I changed my final drive fluid a while back ( 1.5 years) it's been sitting in my garage, bottle tightly sealed. Is it still ok to use or is it Hydroscopic like brake fluid?? I'm not cheap but I hate to buy more if there's no reason.
Erik is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Mar 11th, 2011, 5:58 pm
Addict
 
Join Date: May 2009
Location: , TX, USA
Posts: 746
It's hygroscopic by the way, and gear oil isn't. 1.5 years in a sealed container is nothing for most oils, functionally I would consider it as good as new.
smiller is offline  
post #3 of 3 (permalink) Old Mar 11th, 2011, 9:30 pm Thread Starter
Veteran
 
Join Date: Jun 2003
Location: Lawrenceville, NJ, USA
Posts: 896
Thanks Smiller.
Erik is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rhinewest Cam Gear Install Troubles macdonge Technical, Repair and Maintenance 5 Apr 22nd, 2007 7:33 pm
Rhinewest Cam Gear Install Troubles macdonge K1200RS/GT (Classic) 6 Dec 15th, 2006 8:35 pm
Trouble getting it into first gear. hazard K12/1300GT (Next Gen) 9 Sep 23rd, 2006 9:37 pm
Are you having problems using your heated gear? gsdave K12/1300S 4 Dec 28th, 2005 6:56 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome