'07 K12GT Knock Sensor Fault - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools
Old Feb 24th, 2014, 11:29 pm Thread Starter
Enthusiast
 
oneydee's Avatar
 
Join Date: Jul 2003
Location: , Northwest, USA
Posts: 234
'07 K12GT Knock Sensor Fault

Hooked up my GS911 to my new to me 2007 K12GT and the autoscan report pulled up a fault code:

1 fault code found
10209 Knock-sensor 1 defective
the fault is not present now


Digging further it looks like it was recorded about 200-300 miles ago (while still owned by the previous owner).

Bike has 55K miles on it and is running fine.

Thoughts? I am a GS911 noob so trying to up my skill-set with the device and learn about my new bike at the same time. Should I just clear the fault and go ride the thing or does this require attention? Someone I know already mentioned he thinks it was bad gas and just try to run some ethanol free gas and Techron additive through the next coupla tanks of fuel.


Last edited by oneydee; Feb 25th, 2014 at 9:22 am.
oneydee is offline  
Sponsored Links
Advertisement
 
Old Feb 25th, 2014, 8:32 am
Enthusiast
 
Join Date: Mar 2012
Location: Moyock, NC, USA
Posts: 357
Reset it and ride. That's the nice thing about the 911. You can scan the bike whenever you want. Test it again in a hundred or so miles after you have run it with good gas. If it shows the fault again...replace it.

------------------------------------------------------------------------------------------ Message sent from my Radio Shack TRS-80 using a keyboard and electricity.
moymurfs is offline  
Old Feb 25th, 2014, 1:23 pm
Veteran
 
Robert_W's Avatar
 
Join Date: May 2007
Location: Troy, MT, USA
Posts: 1,658
No ethanol gas was ever put in that machine. Always ran premium ethanol free. Probably from sitting too long. I had the GS-911 hooked up a while back...like last year...never saw that code. I would agree reset it...run a tank or two of new gas through it...and ride the hell out of it.

Have you gotten it out on the highway yet?

'07 GT Sold- 2012 GSA Triple Black - Farkles O'Plenty!

I think I'm diagonally parked in a parallel universe....but I am NOT a Dental Floss Tycoon!
What's with this STUPID Cosmic Door?! ....Going Somewhere?!....Going Somewhere?!


Robert_W is offline  
Sponsored Links
Advertisement
 
Old Feb 25th, 2014, 8:10 pm Thread Starter
Enthusiast
 
oneydee's Avatar
 
Join Date: Jul 2003
Location: , Northwest, USA
Posts: 234
Thanks Robert. Didn't want to bug you with this small stuff so thought I would just put it out on the forum. I will clear it and ride it and then check again later. Have only gotten one ride on it and very few freeway miles. It rode fine but idled inconsistently. Probably has been sitting too long. I hope to change that soon! We've been getting buried with snow. Dang it!
oneydee is offline  
Old Mar 21st, 2014, 7:57 pm
Senior Member
 
Join Date: Dec 2009
Location: Lake Wylie, SC, USA
Posts: 179
After my engine was rebuilt due to cam chain jump and associated damage the Knock Sensor fault would come on every time I went for a ride. Sometimes right away sometimes after 100 miles but it would always trigger at some point. Dealer spent lots of time on the phone with BMW and taking things apart but could never get the fault figured out. I always assumed "Knock" had to do with detonation or ping but according to them it does not. It is some kind of resonance or audible issue, Didn't make any sense to me. I sold it cheap on ebay and disclosed this to the new owner. It would be interesting to know if it ever got rectified. Good luck.

2013 Honda Goldwing F6B
1970 Norton Commando
820,000+ miles on 2 wheels in 39 years

Past experience: 2012 Victory Vision, 2011 Triumph Sprint GT, 2007 K1200GT 88,000 miles and rebuilt, 51 Vincent Special, 08 B-King, 07 Redneck Undresser, 06 K1200 S (final drive failure), 04 ST1300, 04 Hyabusa, 04 Aprilia Futura, 00 Softail, 98 Buell S3T, 98 Electra Glide, 97 Electra Glide, 94 Low Rider, 92 Fatboy, 91 FXRP, 90 Buell RS 1200, 83 Electra Glide, 83 XL Roadster, 74 XLCH, 74 Triumph TR5T plus 6 custom built Hard Tail Choppers!
1951vbs is offline  
 

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is the K12GT for me? hisport K1200RS/GT (Classic) 18 Oct 12th, 2010 1:08 pm
Knock, knock, knock... who's there? cbdane K12/1300GT (Next Gen) 2 Sep 30th, 2008 5:43 pm
MotorCyclist rate ST1300 over K12GT !!! LA-K12GT K12/1300GT (Next Gen) 48 Aug 20th, 2008 10:15 pm
Marsee Corona Tank Bag on K12GT taxswami K12/1300GT (Next Gen) 9 Sep 12th, 2007 11:17 pm
K12S vs K12GT (old model) ratemut K12/1300S 4 Jul 18th, 2006 3:30 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome