06 k12gt Noise under power @50k - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Jul 15th, 2016, 8:30 pm Thread Starter
Noob
 
Join Date: Aug 2013
Location: Escondido, Ca, USA
Posts: 3
06 k12gt Noise under power @50k

Have a 2006 K1200GT with 50k miles. About 700 miles ago started getting some noise with the engine under load at all gears and rpm. Noise has progressively gotten worse and is now quite loud. If i pull the clutch or am in neutral, there is no noise the engine sounds great. Noise is present in decel, accel or anytime engine is applying a load. Read about the timing chain but i would hear the sound at startup or in neutral and i don't. Thanks in advance for the help.
SOFA is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Absolutely the most detailed description of the K1200S I've come across... sinc K12/1300S 20 Jul 19th, 2014 10:04 am
Observations on the first 2500mi with my gently used (I hope!) K12GT BigBite K12/1300GT (Next Gen) 8 Jan 27th, 2012 9:59 am
Extra power point on 2007 K12GT tvtommy K12/1300GT (Next Gen) 7 Oct 9th, 2009 9:06 am
Rukka APR3/AirVantage - Cleaning Instructions remedy451 Apparel 8 Mar 14th, 2008 7:02 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome