Changed your oil Yet????? - K-Bikes.com - Excellence in Motion
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old May 26th, 2006, 6:37 pm Thread Starter
 
Join Date: May 2006
Posts: 16
Changed your oil Yet?????

I was wondering if anyone has changed their own oil yet?
I see the oil filter is on the side, rather way up and under.
I am thinking I can pull the filter with a strap wrench rather than spend
$ 75.00 for the BMW spin-off wrench.
Any thoughts?
MichaelMulroy is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old May 27th, 2006, 7:34 am
Enthusiast
 
billg's Avatar
 
Join Date: Jun 2003
Location: Madison, NJ, USA
Posts: 327
Mike, I haven't changed mine yet. When I do I plan on using the oil filter pliers in the photo. They fit in without removing anything.
Attached Thumbnails
Click image for larger version

Name:	o f p.JPG
Views:	181
Size:	163.4 KB
ID:	2553  
billg is offline  
post #3 of 21 (permalink) Old May 27th, 2006, 7:57 am
The Gov
 
philspace's Avatar
 
Join Date: May 2006
Location: Springfield, VA, USA
Posts: 660
Just out of curiosity, my dealer told that no synth until after 6K and that they were using 10-50 BMW dino for the time being, but would be getting in 10-40 syth for the shop that would be cheaper that Castrol GPS.

Did you guys get the same info. Without syth, I will be changing my own oil at 3K.

Phil Space
Springfield, VA
2007 K1200GT the road beast
2009 F800GS - My little adventure bike.
2007 F800ST - Her's, but I can ride it.
philspace is offline  
Sponsored Links
Advertisement
 
post #4 of 21 (permalink) Old May 27th, 2006, 8:49 am
Enthusiast
 
billg's Avatar
 
Join Date: Jun 2003
Location: Madison, NJ, USA
Posts: 327
Mine didn't get the 1st service till 1600 miles. At that service mobil 1 10W40 motorcycle oil went in. There's no reason to wait, BMW cars come right from the factory with Syn. oil.
billg is offline  
post #5 of 21 (permalink) Old May 27th, 2006, 9:29 am
 
Join Date: Dec 2005
Posts: 18
My dealer told me that I should not use Synthetic due to wet clutch?
Reg01 is offline  
post #6 of 21 (permalink) Old May 27th, 2006, 2:03 pm
Addict
 
Doru-in-Romania's Avatar
 
Join Date: May 2006
Location: Bucharest, , Romania
Posts: 434
my dealer put "m" car oil in my bike at first inspection. 5600km now no fill needed. that's fine, considering i ride fast (140-220km/h).


2010 R1200RT
2009 X6
2010 X1
former and future k owner
Doru-in-Romania is offline  
post #7 of 21 (permalink) Old May 27th, 2006, 3:01 pm
Enthusiast
 
billg's Avatar
 
Join Date: Jun 2003
Location: Madison, NJ, USA
Posts: 327
Quote:
Originally Posted by Reg01
My dealer told me that I should not use Synthetic due to wet clutch?
AS long as it's motorcycle specific syn. it's fine.
billg is offline  
post #8 of 21 (permalink) Old May 27th, 2006, 3:28 pm
The Gov
 
philspace's Avatar
 
Join Date: May 2006
Location: Springfield, VA, USA
Posts: 660
Quote:
Originally Posted by billg
AS long as it's motorcycle specific syn. it's fine.
My dealer told me no synth until after the 6K service. They are using BMW 10W50 DINO until then. I asked them if they would be using the 10W40 Castol GPS and the service manager said they will be using a BMW 10W40 synth that is actually cheaper than the GPS. My sons use the Mobil 1 MX4T which is darn pricey as well.

Phil Space
Springfield, VA
2007 K1200GT the road beast
2009 F800GS - My little adventure bike.
2007 F800ST - Her's, but I can ride it.
philspace is offline  
post #9 of 21 (permalink) Old May 27th, 2006, 8:02 pm
The Gov
 
philspace's Avatar
 
Join Date: May 2006
Location: Springfield, VA, USA
Posts: 660
Quote:
Originally Posted by billg
Mine didn't get the 1st service till 1600 miles. At that service mobil 1 10W40 motorcycle oil went in. There's no reason to wait, BMW cars come right from the factory with Syn. oil.
Our guy is pretty sharp and hasn't let me down in many moons. I will listen to him, and extra dino oil change at 3K is good for the soul anyway.

Phil Space
Springfield, VA
2007 K1200GT the road beast
2009 F800GS - My little adventure bike.
2007 F800ST - Her's, but I can ride it.
philspace is offline  
post #10 of 21 (permalink) Old May 28th, 2006, 7:39 pm
Member
 
Join Date: Jun 2003
Location: Schoten, , Belgium
Posts: 93
Quote:
Originally Posted by philspace
My dealer told me no synth until after the 6K service. They are using BMW 10W50 DINO until then. I asked them if they would be using the 10W40 Castol GPS and the service manager said they will be using a BMW 10W40 synth that is actually cheaper than the GPS. My sons use the Mobil 1 MX4T which is darn pricey as well.
Hi,

My dealer says on the new K motor not to use synthetic at all: half synthetic 10W40 is recommended by BMW??? As a matter of fact he now uses this oil spec in all the BMW motors, be it the R, K, F....

Apparently a lot of different opinions.

What is right now?

Rgds

Luc
Lucsch is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Changed my "R" abit Slow2go K12/1300R/R-Sport 67 Sep 27th, 2006 5:04 am
Re:Fluids changed 007007 K1200RS/GT (Classic) 25 Apr 16th, 2006 9:45 am
I-BMW.com name changed cousi Campfire 22 Dec 22nd, 2005 1:07 pm
changed to 5.5 wheel, mixed tires OK??? kopov260 K1200RS/GT (Classic) 4 Dec 18th, 2005 6:09 pm
just changed oil-i hate germans! billbeemer K1200RS/GT (Classic) 12 Oct 26th, 2005 9:49 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome