K1300gt alternator - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Oct 23rd, 2018, 3:58 pm Thread Starter
Noob
 
Join Date: Oct 2018
Posts: 3
K1300gt alternator

Hi all, had my k1300gt for around 12monts now, regular commuting in and out of London, love it until tonight.

Started bike up, battery light stayed on so started driving home, got about 10miles before losing lights, then instrument cluster died. Breakdown man came said it was alternator. He charged battery up to get me home and on way heard a click and battery started charging again.

Your thoughts 🤔
Russ.3ll is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Oct 23rd, 2018, 5:29 pm
Enthusiast
 
TF1200RT's Avatar
 
Join Date: Nov 2016
Posts: 273
Garage
First, how old is the battery? Second, I would check all of the cables for good connections.

2009 K1300 GT
1984 Kawasaki ZX750-E1 Turbo
1990 Kawasaki ZX600R
2005 R1200 RT - gone
2008 Honda CBR1000 RR - gone

TF1200RT is offline  
post #3 of 5 (permalink) Old Oct 24th, 2018, 5:01 am Thread Starter
Noob
 
Join Date: Oct 2018
Posts: 3
Battery a year old .

Will check terminals now
Russ.3ll is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old Oct 28th, 2018, 4:41 am
Noob
 
Join Date: Oct 2018
Posts: 1
Had a alternator replaced on a RT, by BMW,,, cost me 650 and that was about 10 years ago.

When I checked the price of alternator only that was 480. so got the stealers to do it.

Check those connections..

John,
Axit is offline  
post #5 of 5 (permalink) Old Nov 2nd, 2018, 6:42 am
Senior Member
 
Join Date: Jul 2016
Location: Seattle, WA, USA
Posts: 135
Garage
Here in the States you can get your Alt. rebuilt for pretty reasonable or you can pick up low miles used on eBay for a fraction of what a dealer costs.

I had an unusual Alt. experience when I first bought my '08 K 12 S. After hearing a pulsating whirring sound, I pulled the Alt off and discovered the Drive Plate which carries the Rubber Transfer Bearings had bent out of plane a good 100 thou. When I showed it to the local dealer they said they had never seen that before. I had the Alt. gone thru at a local auto elec. shop and had them replace the bearings. That was 4 or 5 years ago and I haven't had any trouble with the charging system since.
SpaceViking is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
All K1300GT known issues min K12/1300GT (Next Gen) 1 Jul 4th, 2016 6:02 pm
K1300GT Low Beam HID conversion stanretoma K12/1300GT (Next Gen) 2 Apr 14th, 2016 2:25 pm
Has BMW rectified these FAULTS before I purchase K1300GT skeleton K12/1300GT (Next Gen) 33 Nov 11th, 2009 7:56 pm
Alternator diagnostics - bonehead? bratwurstNrice Other K-Bikes Discussion 10 Jul 30th, 2009 11:24 pm
Same final drive in K1300GT as older K1200GT. GMack K12/1300GT (Next Gen) 3 Apr 24th, 2009 10:37 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome