k75 start up - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old Mar 19th, 2011, 8:33 pm Thread Starter
Member
 
Join Date: Sep 2010
Location: , ,
Posts: 99
k75 start up

Well, I've had 10 or so bikes over the years but I just had to tell everyone that last spring I purchased an '87 K75T with 104,000km. Runs great. But I had to tell you about my first start up after a long winters storage.....put in the battery, turn on the key, hit starter.....literally , there was maybe one full rev of the crankshaft and voila...instant life, with no hicupps, burps, or farts!!! It just started and idled as though I had just run it an hour ago!!! Normally I have to do alot of tricks and if I'm lucky I can have the other bikes running in 5 to 15 minutes after winter storage.....but this bike with a half second start up to instant smooth idle just floored me!!!
astroguy is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old Mar 19th, 2011, 9:44 pm
Member
 
TrialsRider's Avatar
 
Join Date: Dec 2010
Location: Kingston, ON, Canada
Posts: 71
That's what you get for buying a three cylinder motorcycle
TrialsRider is offline  
post #3 of 4 (permalink) Old Mar 20th, 2011, 9:48 am
Senior Member
 
Join Date: Nov 2007
Location: Holden, MA, USA
Posts: 172
Quote:
Originally Posted by astroguy
Normally I have to do alot of tricks and if I'm lucky I can have the other bikes running in 5 to 15 minutes after winter storage.....but this bike with a half second start up to instant smooth idle just floored me!!!
That is a special moment. Perhaps it's outdated now, but that Bosch LE-Jetronic fuel injection system was/is a wonderful thing.
Steve
1990 K75RT
stevemac829 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old Mar 20th, 2011, 7:51 pm
Enthusiast
 
chaos's Avatar
 
Join Date: Jun 2008
Location: Moraine, OH, USA
Posts: 305
Mine came out of hibernation with a half a crank. Your's must have horrible unseen, un-noticeable problems.

1987 RED K75S
chaos is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1987 K75s doesnt start bschloss Technical, Repair and Maintenance 16 Jul 31st, 2010 10:02 am
'85 K100 Cutting Out, and Failing to Start. I922sParkCir Other K-Bikes Discussion 17 May 31st, 2010 5:05 pm
Failure to start and failed switch far from home plcedeno K12/1300S 39 Aug 17th, 2009 8:39 pm
'04 GT No Start Condition - tried jump start motorradman K1200RS/GT (Classic) 5 Jun 4th, 2009 9:34 pm
k1200r fails to start sometimes ecapuano K12/1300R/R-Sport 6 Oct 9th, 2008 11:37 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome