'89 K75C running rich.... - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Sep 23rd, 2012, 4:21 pm Thread Starter
Noob
 
bgadds's Avatar
 
Join Date: Sep 2012
Location: houston, tx, usa
Posts: 4
'89 K75C running rich....

Afternoon All, Recently rescued a '89 k75C from a neighbor after it has been sitting for years in his garage. After fixing some electrical issues, got it running this weekend. starts, idles and runs like a champ, but seems to be running rich. Occasionally when letting off throttle i get backfires at the exhaust. pulled and replaced the plugs, which were black with soot. Again, the bike has been stored for years, so vacuum leaks, fuel injectors gummed up, etc are certainly real possibilities.

So, where to start? Anything sound familiar?

Thanks in advance for your help.

B
bgadds is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Sep 27th, 2012, 11:45 am
Senior Member
 
Join Date: May 2011
Location: Fredrikstad, , Norway
Posts: 181
Could be the fuel pressure regulator, measure fuel pressure...should be 2,5 bar.

Next, check the water temp sensor.... measure the resistance between contact 10 and 13 at the FI ECU connector.
You should measure ~2,5 Kohm at 20 degree Celsius.

Inge K.
Attached Thumbnails
Click image for larger version

Name:	kontakt.JPG
Views:	67
Size:	60.7 KB
ID:	13869  
IngeK is offline  
post #3 of 6 (permalink) Old Sep 27th, 2012, 7:40 pm Thread Starter
Noob
 
bgadds's Avatar
 
Join Date: Sep 2012
Location: houston, tx, usa
Posts: 4
i will check both of these this weekend. thanks.....
bgadds is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old Sep 28th, 2012, 5:13 pm
PsyKotic Waterfowl
 
Join Date: Aug 2006
Location: Seattle, WA,
Posts: 1,328
"They all do that." K75s backfire under moderate to heavy engine braking so its likely there's nothing wrong it.
FlyingDuck is offline  
post #5 of 6 (permalink) Old Sep 29th, 2012, 5:46 pm
Senior Member
 
stokester's Avatar
 
Join Date: Oct 2010
Location: Yorktown, VA, USA
Posts: 163
Quote:
Originally Posted by FlyingDuck
"They all do that." K75s backfire under moderate to heavy engine braking so its likely there's nothing wrong it.
Yup, sounds like mine. Runs great but will get a backfire under heavy engine braking.

Nick
1993 K75S
1991 R100RT
1982 Yamaha XJ650RJ Seca
1978 R100S
stokester is offline  
post #6 of 6 (permalink) Old Oct 7th, 2012, 12:14 pm
Rookie
 
robmack's Avatar
 
Join Date: Apr 2009
Location: Toronto, , Canada
Posts: 53
My K75 burbles and afterfires under engine braking as well, however it will give a good bang if I quickly roll off the throttle to engine brake from highway speeds. I collected this information from various sources in my efforts to cure this behaviour:

1) check that the throttle position switch on the rear of the throttle bodies is working properly.

2) there is an air by pass that adjusts the fuel mixture at low air speeds .. under the fuel tank inside the air box. This is normally set with a CO2 meter..

3) Another cause of afterfiring could be leakage in the first 20" or so of the exhaust system. I have read that the gasket between the headers and muffler can deteriorate, causing the leakage. Consider using Permatex Ultra-Copper high temp RTV silicone gasket maker #101BR to seal that joint. It might also be an idea to replace the copper gaskets at the engine exhaust ports to ensure no leakage at those points either.

- Robert

Last edited by robmack; Oct 8th, 2012 at 8:50 am.
robmack is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Absolutely the most detailed description of the K1200S I've come across... sinc K12/1300S 20 Jul 19th, 2014 10:04 am
K75C ignition/starting problem redtank Other K-Bikes Discussion 15 Jan 8th, 2012 8:01 pm
Oil Pan Leak - 1986 K75C pallum Other K-Bikes Discussion 2 Sep 25th, 2010 2:07 pm
Blinkers as running lights EvilGenius K12/1300R/R-Sport 7 Jan 1st, 2010 2:22 pm
My GT is running rich craigj K1200RS/GT (Classic) 4 Nov 26th, 2008 7:49 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome