K75rt Alternator light not lighting up - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Jul 17th, 2013, 5:04 am Thread Starter
Noob
 
Join Date: Jul 2009
Location: Woumen, , Belgium
Posts: 23
K75rt Alternator light not lighting up

Hi,

Just recently my K75rt alternator idiot light has started acting up.

First it was not lighting up when turning on the ignition but came to life after starting (and then it would work as intented: i.e. go out when the rev's where at around 1000-1500 at cold start). After this first start it would usually work ok for the remainder of the day.

I've cleaned the battery and alternator contacts (both red and blue wire) which seemed to cure the problem. This was last week
But now I've noticed it briefly lighting up at starting this morning. yet after my ride it would not turn on anymore.

Any ideas as to what is the cause? Am I in for an alternator rebuild, or is it rather an iffy connector?

As always: thanks in advance!

'92 K75RT (ex-police)
dietbrand is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jul 17th, 2013, 9:11 am
Member
 
Join Date: Dec 2012
Location: York, PA, United States
Posts: 106
Quote:
Originally Posted by dietbrand
Hi,

Just recently my K75rt alternator idiot light has started acting up.

As always: thanks in advance!
Possibly a bulb coming to the end of its life. Disassembling the instrument housing isnt that bad once you remove it. Bulb replacement is easy. Just be gentle the first time until you figure out how things fit together. Do all of the bulbs once the case is open. Bulbs should be available at an auto parts store. I changed over to red for speedo and tach lighting. Much better than the stock green.

The other option is to forget about the idiot light and buy a voltmeter. A nice digital unit is available from www.bikemeters.com for about $65. Critical on 90s Triumphs with sprag clutches that explode when starting with undercharged batteries. Excessive cranking on the K75 gets you a fused starter relay which results in the starter turning until the battery dies. Embarrassing but not ungodly expensive to fix.

Last edited by 97tiger885; Jul 17th, 2013 at 9:32 am.
97tiger885 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
hot k75rt shutting down alesi348 Technical, Repair and Maintenance 1 Aug 8th, 2008 10:24 pm
Lighting that didn't work! jpel Lighting 0 Aug 5th, 2008 9:53 pm
K75RT Wheel removal flippa Other K-Bikes Discussion 3 Jan 7th, 2008 9:32 am
Lighting Section jskene1 k-bikes Contact the Help Team 1 Aug 13th, 2007 9:16 pm
Auxiliary Lighting? gsdave K12/1300S 3 Dec 10th, 2005 8:53 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome