K1200 LT no indicators - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Jul 14th, 2017, 6:49 am Thread Starter
Noob
 
Join Date: Jul 2017
Posts: 1
Thumbs down K1200 LT no indicators

Hello y'all
I just changed the cruise control cable, and now I have no indicators. Checked all the fuses, and taken LH panels off again to see if I disturbed a connector.
At a loss now, anyone any ideas?
all indicators dead including hazards.
daglocks is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New K1200 GT owner and member. FredBGG K1200RS/GT (Classic) 0 Mar 8th, 2015 1:56 pm
K1200 R and S air box parts compatibility Titanium5 K12/1300R/R-Sport 22 Jun 2nd, 2014 7:45 pm
2008 BMW K1200 GT For Sale Boston Bagger Bikes 7 Aug 12th, 2013 4:51 pm
BMW's K1200 R voted Motorcycle of the Year 2005! LOCUS K12/1300R/R-Sport 13 May 20th, 2007 11:01 pm
Warning Re Aftermarket Indicators and Electronics TheJoker K12/1300R/R-Sport 9 Jul 22nd, 2006 2:55 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome