K1200LT cruise control won't engage - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Apr 23rd, 2018, 3:43 pm Thread Starter
Noob
 
Join Date: Apr 2018
Posts: 1
K1200LT cruise control won't engage

The Cruise control on my 2000 K1200LT started kicking out with a harsh bump in road. It was usually immediately deployable again but then it would not engage at all. I went through the test procedure. Everything checked out except the the rear wheel brake pedal switch test. The "SET" light on the dash goes out after 5 seconds of depressing the pedal, but does not come back on after I release the the brake. And the the "SET" light does not go off and on when I spin the rear wheel. It's just off. I could just invest in another micro switch for the rear wheel brake but I feel it's unlikely that this is the problem since the switch works fine for activating the brake lights. Any ideas would be much appreciated. Thanks

Last edited by mountaincur; Apr 24th, 2018 at 2:02 pm. Reason: More info
mountaincur is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Apr 27th, 2018, 10:34 pm
Rookie
 
Sunchaser's Avatar
 
Join Date: Feb 2010
Location: Largo, FL, USA
Posts: 44
Mine acted the same way. Check the micrswitch at the rear pedal. My switch body rotated very slightly on the screw but it was enough to trip the switch when a bump was hit. I wedged a splinter of wood beteen the switch and the casting so it could no longer rotate and the problem never occurred again.

Good luck, ride safe!

"Cogito ergo zoom!"
Safety comes before speed. - Check the dictionary.

1999 Sportster "S" Cardinal Red
2000 ZRX1100 Jade Green
2003 K1200RS Pacific Metallic Blue
Sunchaser is offline  
post #3 of 3 (permalink) Old Jul 12th, 2018, 11:54 pm
cws
Senior Member
 
cws's Avatar
 
Join Date: Oct 2005
Location: Sydney, NSW, Australia
Posts: 137
Quote:
Originally Posted by mountaincur View Post
The Cruise control on my 2000 K1200LT started kicking out with a harsh bump in road. It was usually immediately deployable again but then it would not engage at all. I went through the test procedure. Everything checked out except the the rear wheel brake pedal switch test. The "SET" light on the dash goes out after 5 seconds of depressing the pedal, but does not come back on after I release the the brake. And the the "SET" light does not go off and on when I spin the rear wheel. It's just off. I could just invest in another micro switch for the rear wheel brake but I feel it's unlikely that this is the problem since the switch works fine for activating the brake lights. Any ideas would be much appreciated. Thanks
Don't know if you got this sorted or not... but have you tried putting some WD40 or other water dispeller around the switch? If its not disengaging it could just be there's crud in there fouling it. You should hear a distinct "click" when pressing the pedal, and another "click" when it releases... put some spray on there and work it a bit... I know that's fixed similar issue for others when all else passes the test but rear pedal.

Chris
Sydney, NSW
2005 Dark Graphite Metallic K1200LT
2005 Orient Blue Metallic K1200GT SE
Ulysses #45310
GS911

cws is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise control K1200rs problem trebor99 Technical, Repair and Maintenance 1 Jul 7th, 2015 2:02 pm
Cruise Control Failure BMW-Mike K1200RS/GT (Classic) 11 Oct 1st, 2012 12:43 am
TPS Works Better & Cruise Control Fix solarmoose K12/1300GT (Next Gen) 2 Nov 20th, 2011 7:22 am
Change the minium speed to engage the Cruise Control? Flere-Imsaho K12/1300GT (Next Gen) 19 Aug 24th, 2010 9:30 pm
Integral ABS and ASC - New Riding Dynamic Control Systems for BMW Motorcycles SilverRT K12/1300GT (Next Gen) 1 Jul 14th, 2006 4:09 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome