Stebel Nautilus Not functioning - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Aug 31st, 2008, 2:18 pm Thread Starter
Noob
 
aljax's Avatar
 
Join Date: Apr 2008
Location: Jacksonville, Fl, USA
Posts: 3
Question Stebel Nautilus Not functioning

Hi folks,

First thread since I purchased my '04 K12rs 4 months ago.....just got back from BMW dealership who did my 12,000 mi. service and installed a Stebel Nautilus. The horn worked 3 times before it just died! I looked at all the connections and they look intact. Any words of advice? Has this happened to you??

Thanks

AL
aljax is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Aug 31st, 2008, 10:30 pm
Enthusiast
 
brentboshart's Avatar
 
Join Date: Jul 2003
Location: Atwood, Ontario, Canada
Posts: 398
Fuse? I had problems with my relay, it kept blowing. I realized the way it was oriented, it collected water. Once positioned properly, I've had no problems since.

Brent Boshart
10 R1200GS ADV (his)
09 K1300S Light Grey (hers)
brentboshart is offline  
post #3 of 6 (permalink) Old Sep 1st, 2008, 12:44 am
Enthusiast
 
rebeltown's Avatar
 
Join Date: Jun 2008
Location: , NJ, USA
Posts: 233
Trace the wiring from switch to air compressor and see where you have power and where you don't. Agree, first check fuses, connections and try to jumper power right to the compressor to see if it has seized or if it works properly. Keep us abreast...

Gary
2007 K1200GT
Dark Graphite Grey
New Jersey-Don't Laugh!
rebeltown is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old Sep 1st, 2008, 10:25 pm Thread Starter
Noob
 
aljax's Avatar
 
Join Date: Apr 2008
Location: Jacksonville, Fl, USA
Posts: 3
Stebel

Thanks, Will do and keep you posted, Hurricane coming this way, not much riding going on. What a great source of info, great site!!

Thanks Again,

AL
aljax is offline  
post #5 of 6 (permalink) Old Sep 2nd, 2008, 11:05 am
Riding in company
 
BillA's Avatar
 
Join Date: Oct 2005
Location: Rumson, NJ, USA
Posts: 291
Al, the Nautilus draws a lot of current. For that reason, most use the horn circuit to trigger a relay which then brings power to the horn through nice fat wires. Perhaps your dealer didn't do that..perhaps he just bolted the Nautilus on and hooked up your stock wiring. You'd think that the dealers would always do things the best way, but they don't. Check your fuses; you may well have blown the fuse.

The Nautilus is a great horn and you're gonna love it. But get big wires to it. It has been mentioned on these forums that restricting the amount of current available to the horn (like by sticking with relatively small gauge wire) may decrease its loudness. Then there's the water thing, too, but you don't hear so much about it. Good luck.

BillA
Jersey Shore
K1200RS '04
BSA Victor '68ish
Club Car golf cart '92
BillA is offline  
post #6 of 6 (permalink) Old Sep 6th, 2008, 11:16 am Thread Starter
Noob
 
aljax's Avatar
 
Join Date: Apr 2008
Location: Jacksonville, Fl, USA
Posts: 3
Hi,

Checked all of above. Direct to horn 12 V and horn works fine. Fuse is solid and intact. Attached voltmeter and no current is getting to the horn wires. Has to be between the fuse box and horn. Any further reccs?? May have to drive it 1.5 hours back to dealer.

AL
aljax is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Another Stebel Nautilus install...on an '06 GT. messenger13 K12/1300GT (Next Gen) 27 Apr 17th, 2008 9:24 pm
Stebel Nautilus chuckwilmot K12/1300GT (Next Gen) 29 Mar 20th, 2008 9:18 pm
Stebel Nautilus Horn Install motorrad4fun K1200RS/GT (Classic) 6 Nov 16th, 2007 6:14 am
Stebel Nautilus Horn brentboshart Accessories 7 Jul 28th, 2006 11:55 am
Stebel Horns - Nautilus vs. Magnum - Opinions? Kaos968 K12/1300S 18 Apr 29th, 2006 8:40 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome