K100-87, fuel pump fuse blows, new pump - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Jun 18th, 2007, 6:22 pm Thread Starter
 
Join Date: Jun 2007
Posts: 1
Angry K100-87, fuel pump fuse blows, new pump

I just put a new fuel pump in a friends K100. It has been sitting for a year or two, and "supposedly" ran when put away. I changed out the fuel pump. Everything seems to work except when I crank it, the fuse for the fuel pump blows, whether the tank is plugged in or not.

Any idea where the short or problem may be? As it blows whether the pump is plugged in or not, it must be some wiring problem.

I guess I changed a good pump, but, I need to fix this.

Help?
just66horns is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Jun 18th, 2007, 10:07 pm
Looking for better limits...
 
Razel's Avatar
 
Join Date: Jun 2003
Location: Fremont, CA, USA
Posts: 5,163
Kind of out in left field, but did you change the fuel filter? Pump may be drawing a lot of current trying to pump past the filter to the injectors.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

Ray
2010 K1300GT Royal Blue
2003 K1200GT Orient Blue (for sale)
2007 G650 X-Challenge

IBA #34158

Be a K-Bikes Supporter

I work for Keyser SŲze
Razel is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Absolutely the most detailed description of the K1200S I've come across... sinc K12/1300S 20 Jul 19th, 2014 9:04 am
Dissolving fuel pump damper...? Beemer01 Other K-Bikes Discussion 6 Dec 1st, 2006 11:09 pm
Help - No start after Removing Quick Disconnects DaveTheAffable K1200RS/GT (Classic) 80 Sep 25th, 2006 9:45 am
K75 fuel pump fuse blowing... dlloyd Other K-Bikes Discussion 1 Sep 5th, 2006 6:14 pm
Fuel Pump Flange Nut Tool southerndude Technical, Repair and Maintenance 9 May 24th, 2006 3:03 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome