Squealing Clutch Revisited - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Feb 15th, 2008, 6:27 pm Thread Starter
Senior Member
 
erniejen's Avatar
 
Join Date: Jan 2007
Location: San Diego, Ca, USA
Posts: 146
Squealing Clutch Revisited

I know this noisy clutch issue has been publicized over the forum in hundreds of messages, but I have a lingering question. That is, on the 06 and early 07s that received the rework to the transmission input shaft, did the noise go away as a result of this rework?
The reason I am asking about this issue is that I had the entire assembly replaced on my 07 "redesigned" clutch after 13K miles with signs of wear on the contact plate. After less that 1k miles the noise has returned and is progressing to get worse as before. Recently (18K mile service), we decided to change the oil from dino to synthetic oil to see if this would improve the lubrication process. After almost 600 miles there has been no significant improvement to the increasingly audible and potentially wearing problem.
So my question to all of you that have received the rework is: "Did it work? Did the noise go away?" Your comments will help in my approach to a final solution on this problem.
EJ
erniejen is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch replacement Bronston K12/1300S 10 Jul 11th, 2011 10:57 am
clutch cable problems!!!!!!!!!!!!!! gabriel Technical, Repair and Maintenance 1 Nov 12th, 2007 3:22 am
Another Clutch Observation matanuska K1200RS/GT (Classic) 1 Dec 15th, 2006 6:35 am
Hydraulic clutch symptoms? kevin_stevens K1200RS/GT (Classic) 18 Aug 14th, 2006 6:18 pm
Clutch questions 03 K12GT tyggyr K1200RS/GT (Classic) 12 Oct 18th, 2005 2:00 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome