04 K12RS Won't Start Whirring Sound - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Mar 2nd, 2008, 8:01 am Thread Starter
Noob
 
TwoBearBill's Avatar
 
Join Date: May 2005
Location: Mena, AR, USA
Posts: 20
04 K12RS Won't Start Whirring Sound

When I turned on the ignition to start my bike, all the instrument lights come on, there is an extra whirring sound, and the starter switch does nothing. I assume the normal sound before was the electric fuel pump, but this sounds different. I've removed the battery and I'm charging it now to be sure it has a full charge. This is the first time I've completely unhooked and removed the battery. Any precautions before I put it back in a try to start the bike again?
TwoBearBill is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Mar 2nd, 2008, 10:20 am
Addict
 
Join Date: Mar 2004
Location: , , UK
Posts: 3,750
Had you been cranking the bike long and hard before this and flattened the battery?

If so, you may have welded the starter relay contacts together and you shouldn't let the bike 'whirr away' for too long, in case you do more damage. It's also possible the starter switch itself could be stuck on. The starter relay is in the relay box on the right side - plastics and tank off I'm afraid.

The only other thing that makes a whirring noise is the fuel pump which stops after about 5 seconds when you first turn the key, unless there's no gas in the tank.



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
voxmagna is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
K100RS Won't Start Mudbug Other K-Bikes Discussion 8 Oct 13th, 2008 12:45 pm
Bike won't start after fuel line QD replacement cycletherapy Technical, Repair and Maintenance 16 Dec 18th, 2007 1:34 pm
Jump start? jebnash K12/1300GT (Next Gen) 11 Aug 3rd, 2007 1:39 pm
Help! Remus On 99 K12rs Will Not Start 1200rs Technical, Repair and Maintenance 20 May 14th, 2007 10:03 pm
Help - No start after Removing Quick Disconnects DaveTheAffable K1200RS/GT (Classic) 80 Sep 25th, 2006 9:45 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome