Speedo says moving when still - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old Nov 30th, 2005, 4:33 pm Thread Starter
 
Join Date: Jul 2003
Posts: 764
Question Speedo says moving when still

When stopped at traffic lights, my speedo claims I'm going between 18 to 28 mph. If I pull in the clutch and rev a bit, it steadies. Putting on the brake makes it more erratic.

At first this misbehavior happened only when the bike was first cranked for the day. After lying for awhile (about a block), it told the truth for the rest of the ride. But recently it's gotten worse and now lies all the time at idle. On the highway, speedo indicates same as GPS.

I remember this being discussed a long time ago, but don't remember what cause was found. Does anybody know what causes this and what to do about it?
allenclarkson is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old Nov 30th, 2005, 5:58 pm
 
Join Date: Aug 2003
Posts: 1,047
Quote:
Originally Posted by allenclarkson
When stopped at traffic lights, my speedo claims I'm going between 18 to 28 mph. If I pull in the clutch and rev a bit, it steadies. Putting on the brake makes it more erratic.

At first this misbehavior happened only when the bike was first cranked for the day. After lying for awhile (about a block), it told the truth for the rest of the ride. But recently it's gotten worse and now lies all the time at idle. On the highway, speedo indicates same as GPS.

I remember this being discussed a long time ago, but don't remember what cause was found. Does anybody know what causes this and what to do about it?
Allen: I found the thread:
http://www.k-bikes.com/ubbthreads/sh...=&view=&sb=&o=
Mark
mbohn is offline  
post #3 of 5 (permalink) Old Nov 30th, 2005, 6:13 pm
 
Join Date: Jun 2003
Posts: 23
When I was having trouble with the brakes on my 02 KRS the speedo would occasionally climb while standing still when the front brake lever was pulled. Since I had the servo unit replaced it hasn't done it.
Bill_K is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old Dec 1st, 2005, 8:37 am Thread Starter
 
Join Date: Jul 2003
Posts: 764
Quote:
Originally Posted by mbohn
Thanks for finding it - I could have looked harder.

The only concrete thing there was Bear's report on a problem with the pickup in the final drive. Getting that right fixed his problem, but it can't be what's wrong with my bike.

Tony Beattie (Serv Mgr at Max BMW) says he's seen it only once before - on a new LT. When he couldn't get that bike to do right and asked BMW for help, they said it was something being worked on in Germany - i.e., a known problem with no solution yet. But if that's so (certain that's what BMW told Tony), I am surprised it hasn't been discussed here more than what was in that thread.

Had forgotten how your Speedo kept moving - she musta looked pretty sharp
allenclarkson is offline  
post #5 of 5 (permalink) Old Dec 2nd, 2005, 4:08 pm
 
Join Date: Jan 2004
Posts: 41
My cluster was swapped with a known stable one by an NY dealer while on the road. The new speedo does not wander while idling.
turbocohen is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
K1200S Speedo Question.. Need Advice and a Hug Pirate K12/1300S 12 Nov 3rd, 2005 5:45 pm
flickering speedo needle 3725dave Technical, Repair and Maintenance 4 Oct 21st, 2005 2:40 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome