87 K100 Tach problem. - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Sep 24th, 2009, 7:23 am Thread Starter
 
Join Date: Sep 2009
Posts: 3
Question 87 K100 Tach problem.

Greetings fellow K-bike owners. My trusty 87 K100 recently developed a tachometer problem after a recent headlight bulb change.

The engine revs well pass 2000 rpm, but the tachometer needle does not travel pass 2000 rpm.

I've checked is the backplate of the tach is warped, but it is not, there is plenty of room for the needle to move pass 2000 rpm.

Any suggestions what could be the problem?
87K100 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Sep 26th, 2009, 12:52 pm
Looking for better limits...
 
Razel's Avatar
 
Join Date: Jun 2003
Location: Fremont, CA, USA
Posts: 5,163
Give this a shot ... from www.ibmwr.org Tech pages.

http://www.ibmwr.org/ktech/tach-fix.shtml

Good luck with it, too.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

Ray
2010 K1300GT Royal Blue
2003 K1200GT Orient Blue (for sale)
2007 G650 X-Challenge

IBA #34158

Be a K-Bikes Supporter

I work for Keyser Söze
Razel is offline  
post #3 of 3 (permalink) Old Sep 29th, 2009, 9:58 am
Addict
 
Join Date: Mar 2004
Location: , , UK
Posts: 3,750
Quote:
Originally Posted by 87K100
Greetings fellow K-bike owners. My trusty 87 K100 recently developed a tachometer problem after a recent headlight bulb change.

The engine revs well pass 2000 rpm, but the tachometer needle does not travel pass 2000 rpm.

I've checked is the backplate of the tach is warped, but it is not, there is plenty of room for the needle to move pass 2000 rpm.

Any suggestions what could be the problem?
Take the tacho out of the housing and connect it up. Run the bike. If the tach. needle runs OK past 2K then follow Razels links to stop the needle sticking to the clear front.

If the tach. still sticks out of the housing, then either the needle is touching the back plate or possibly some dirt is trapped in the moving coil. VERY CAREFULLY use a toothpick on the needle near the center and see if you can move it all the way up (without sticking). That may be enough to dislodge what could be in there, but anything magnetic will just stay stuck, so you need to have a careful look with an eyeglass. The needle should move very easily. If it seems tight to move, then a small drop of watch oil from a hypo on the top and bottom jewel bearings will probably fix it (but it won't get fixed if you get oil on the hair springs!) Don't think about using an air line as it will screw up the hair springs - but one of those camera lens blowers should be ok.

Once you are sure the meter movement is mechanically free to move past 2K, if it still doesn't then the fault could be on the circuit board.



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!

Last edited by voxmagna; Sep 29th, 2009 at 10:04 am.
voxmagna is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
84 K100 Rear Brake problem 9533Zero Other K-Bikes Discussion 6 Feb 9th, 2009 2:01 pm
Do you have an idle problem on your K brick? voxmagna Technical, Repair and Maintenance 8 Jan 17th, 2008 3:33 am
accelerator problem bluesrock57 K12/1300GT (Next Gen) 4 Oct 19th, 2007 3:15 am
K100 Speedo Problem 9533Zero Bike Talk 7 Jul 11th, 2007 5:05 pm
K100 Speedo Problem 9533Zero Other K-Bikes Discussion 1 Jul 7th, 2007 4:15 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome