K75s Electrical - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old Apr 17th, 2011, 1:15 am Thread Starter
Noob
 
Join Date: Apr 2011
Location: Norwich, Norfolk, UK
Posts: 1
K75s Electrical

Hello K People. Whilst measuring up for some handlebars for my `93 K75s the back of the ignition switch touched the bar clamps which made a horrible `crackling` sound and now I have no power. The little `blade` fuses are fine and the clock still works but nothing else. What have I blown?. Any help would be great, Thanks
Cudachris is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Apr 17th, 2011, 8:31 am
Veteran
 
H96669's Avatar
 
Join Date: Jun 2009
Location: Burton, British Columbia, Canada
Posts: 1,613
Note to self, always disconnect the battery when doing anything close to the wiring.

It has been a while for me, but shouldn't there be a cover over the switch/wires ? Certainly not BMW's habit of leaving anything exposed like that.

Have a good look at the wiring at the switch first ,just because that is where the problem started...!

Check the grounds, Frame/Battery, I have seen it happen, grounds not too clean or tight at first then a short and suddenly.....no more ground or maybe.....just enough to run the clock.

If not that, then it is on to the relays.

Benelli 50cc at 14
Yamaha RD 200 at 16
Yamaha RD 350 at 17
Honda CB 750 F at 18
Honda V45 Sabre at 24
BMW K100RS at 27
BMW R100GS at 34
BMW K1200RS at 53
H96669 is online now  
post #3 of 3 (permalink) Old Sep 17th, 2011, 5:35 am
Noob
 
Join Date: Sep 2011
Location: Camden, New Jersey, United states
Posts: 3
Right that whenever any electrical problem found , then always first check the cable connection and if not so then check the switch or part. And none from this then surely battery problem.
Rwnauli is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
K75S electrical issue Loomesy Other K-Bikes Discussion 1 Aug 6th, 2010 9:56 am
New K75s owner seeking tire advice metalman Other K-Bikes Discussion 11 May 26th, 2010 8:41 pm
K75S - Help! - Lost cylinder...electrical? neilkamman Other K-Bikes Discussion 6 May 17th, 2009 8:46 pm
K75S Fairing Remove? alexpetrovich Other K-Bikes Discussion 10 Apr 4th, 2009 9:22 pm
New k75 owner, questions on shifting and weird electrical problem, need help! random903 Other K-Bikes Discussion 6 Jul 9th, 2008 7:07 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome