K75 Starter wont work - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old Aug 13th, 2013, 9:32 pm Thread Starter
Noob
 
Join Date: Aug 2013
Location: Enterprise, AL, US
Posts: 4
K75 Starter wont work

I have starter trouble with my 1987 K75S,I rode it to work one day and everything was fine. At the end of the day I attempted to start it and nothing, I could her the fuel pump buzz and a relay click when I pressed the starter button. I got a bump start from a buddy and went home. I assumed it was the starter relay and ordered one and installed it and it did not fix the problem, I was worried that I might have got a bad relay and I tested it in my K1 and it was fine, as well as the old relay, I have checked all fuses and cleaned all grounds and the battery is new. With the tank off I can hear the fuel injection relay buzz when I press the starter button. I also tested the starter and it seems to be fine. I'm not sure what else to do next, would appreciate any advice. Thanks
Steve
SDamron is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old Aug 14th, 2013, 7:47 am
Senior Member
 
stokester's Avatar
 
Join Date: Oct 2010
Location: Yorktown, VA, USA
Posts: 163
Quote:
Originally Posted by SDamron
I have starter trouble with my 1987 K75S,I rode it to work one day and everything was fine. At the end of the day I attempted to start it and nothing, I could her the fuel pump buzz and a relay click when I pressed the starter button. I got a bump start from a buddy and went home. I assumed it was the starter relay and ordered one and installed it and it did not fix the problem, I was worried that I might have got a bad relay and I tested it in my K1 and it was fine, as well as the old relay, I have checked all fuses and cleaned all grounds and the battery is new. With the tank off I can hear the fuel injection relay buzz when I press the starter button. I also tested the starter and it seems to be fine. I'm not sure what else to do next, would appreciate any advice. Thanks
Steve
I'd clean the starter -> Starter Service

Nick
1993 K75S
1991 R100RT
1982 Yamaha XJ650RJ Seca
1978 R100S
stokester is offline  
post #3 of 6 (permalink) Old Aug 14th, 2013, 8:02 am Thread Starter
Noob
 
Join Date: Aug 2013
Location: Enterprise, AL, US
Posts: 4
Thanks Nick, I will give it a try
SDamron is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old Aug 14th, 2013, 10:13 am
Veteran
 
H96669's Avatar
 
Join Date: Jun 2009
Location: Burton, British Columbia, Canada
Posts: 1,613
You may have some bad commutators in the starter. That's the part where the brushes run onto, all divided in rectangles and each one of them is a commutator. Multimeter set to Ohms..one lead to the armature and then touch each commutator in turn with the other lead. They should all show contact.

If one doesn't and the starter stops at that point then it won't spin again.

EuroMotoelectrics has BMW starters...rebuilt I think and for not much vs the price of a new OEM.

Benelli 50cc at 14
Yamaha RD 200 at 16
Yamaha RD 350 at 17
Honda CB 750 F at 18
Honda V45 Sabre at 24
BMW K100RS at 27
BMW R100GS at 34
BMW K1200RS at 53
H96669 is offline  
post #5 of 6 (permalink) Old Aug 14th, 2013, 12:07 pm Thread Starter
Noob
 
Join Date: Aug 2013
Location: Enterprise, AL, US
Posts: 4
At one point I did remove the starter and tested it and it worked, should I still test the commutators? Thanks
SDamron is offline  
post #6 of 6 (permalink) Old Aug 14th, 2013, 4:04 pm
Veteran
 
H96669's Avatar
 
Join Date: Jun 2009
Location: Burton, British Columbia, Canada
Posts: 1,613
Quote:
Originally Posted by SDamron
At one point I did remove the starter and tested it and it worked, should I still test the commutators? Thanks
Anyone doing autoelectricals your way?....they'd test the other parts also.But in these days of cheap available starters & alternators most of them shops are gone. There can be more than a bad commutator as the armature itself may be cooked. You'd need what we called a growler back then, big electromagnet. It has been a long time since I did that in a shop but yes check the commutators, that's easy and what we always did first.

Benelli 50cc at 14
Yamaha RD 200 at 16
Yamaha RD 350 at 17
Honda CB 750 F at 18
Honda V45 Sabre at 24
BMW K100RS at 27
BMW R100GS at 34
BMW K1200RS at 53
H96669 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starter removal, K1200RS. H96669 Technical, Repair and Maintenance 8 Dec 6th, 2018 8:50 pm
K75 Starter wont work SDamron Technical, Repair and Maintenance 0 Aug 13th, 2013 9:26 pm
85 K100 Starter Not functioning and rain short lukeman Other K-Bikes Discussion 18 Jun 9th, 2012 2:56 pm
Sticking starter motor Lucsch K12/1300GT (Next Gen) 27 Feb 8th, 2011 4:36 am
Starter cutting out. lukeman Other K-Bikes Discussion 7 Aug 23rd, 2010 5:21 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome