2006 K12R Rear Brake issue - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old Mar 25th, 2015, 4:13 pm Thread Starter
Noob
 
Join Date: Mar 2015
Location: Hollywood, Florida, USA
Posts: 1
2006 K12R Rear Brake issue

Hey guys. New to K-bikes.com.
Just bought a 2006 K12R with only 7k miles; ( also own a 2004 R1100S.) Here is my problem:
My 2006 K12R's rear brakes only work properly the first 3 or 4 times that I apply them. After that distance they seem to only have 5% of their power, ie. the bike will not come to a stop from 30 mph in 100 feet applying the rears !!!
I have red "Brake Failure" and "Warning" blinking lights on my instrument panel after the bike is started. The rear brakes seem to reset themselves after I shut the bike off for a few minutes and will work again for the next 3-4 times they are applied. . My front brakes work well.
All fluids were changed at the BMW dealer for $500 about a year ago(oil,brakes, transmission, radiator, etc.) As you may tell by the year and mileage the bike was barely used; it was kept covered and indoors. I purchased from a very close friend so I don't have suspicion he is hiding anything from me... actually we are waiting to go riding because he just bought a new BMW.
The BMW dealer in Ft. Lauderdale claimed their computer only showed a "brake fault" reading. The mechanic also said he has seen these Servos go bad ($2000 fix !!!) but it could also be a simple solution... pretty weird answer in my opinion; especially when my buddy had just given them $11,000 for another bike !!!
Could it be the seals ? The brake lines? Need another bleeding? Pls help. IRVING
Mobichair is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old Aug 17th, 2015, 10:51 pm
Noob
 
Thunderhead308's Avatar
 
Join Date: Aug 2015
Location: San Antonio, Texas, USA
Posts: 10
Have you checked the brake pad wear in the rear? I've noticed on mine that they're needing replacing but take about that same distance to slow down as you discribed. If it's been that long since a service maybe you should take it again or find someone who does work on BMWs outside the dealer.

"Hold yer line..."
Thunderhead308 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
SIB 3400806060 rear brake lever wilrobasy K12/1300R/R-Sport 6 Jan 24th, 2009 1:38 pm
Rear brake pedal close-up pics required OX-34 K12/1300R/R-Sport 7 Jan 2nd, 2009 8:11 pm
BMW DOES HAVE A Fix for Rear Brake pedal Shelley K12/1300S 4 Mar 29th, 2007 12:17 pm
No Rear Brake Pedal Pressure stagrider K1200RS/GT (Classic) 3 Dec 17th, 2006 11:22 am
K12r rear brakes StuartBrody K12/1300R/R-Sport 43 Mar 26th, 2006 9:16 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome