1987 K75 start button and light problem - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old May 19th, 2016, 6:44 pm Thread Starter
Noob
 
Join Date: May 2016
Location: Janesville, WI, USA
Posts: 1
1987 K75 start button and light problem

Last week the greenish blue start button popped off after starting my bike. I Didn't think much of it because it still worked fine. Yesterday while riding it I lost the headlight, the taillight, and the directionals. When I got home and turned the bike on the starter was still running and would not stop even when I removed the key, so I turned the bike back to on so it would run then I disconnected the battery so it would shut off. I have no idea where to start with this, when it is running there is no problem except for the lights being out. I also checked the fuse box and everything is fine there. Any help would be greatly appreciated.
TheGunner832 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old May 19th, 2016, 8:40 pm
Rookie
 
Join Date: Aug 2007
Location: El Paso, TX, USA
Posts: 41
Again,motobrick.com is the best place to get good answers.

Larry Johnson
El Paso Tx
ljjohns is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Absolutely the most detailed description of the K1200S I've come across... sinc K12/1300S 20 Jul 19th, 2014 10:04 am
Fail to start, jump start works ok - ideas? quintaar K1200RS/GT (Classic) 15 Jan 17th, 2012 11:50 pm
18K Service - How many hours? Captain K12R K12/1300R/R-Sport 8 Jun 17th, 2011 12:18 pm
Camos BTS-200 bluetooth helmet headset review CrazyCzech K12/1300R/R-Sport 25 Sep 3rd, 2009 7:38 pm
New bike gone bad: Cruise Control kniewiderstand K1200RS/GT (Classic) 13 Aug 19th, 2007 6:29 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome