Metallic 'tick' and 'clank' at front - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old May 25th, 2006, 10:17 am Thread Starter
Addict
 
Join Date: Mar 2004
Location: , , UK
Posts: 3,750
Metallic 'tick' and 'clank' at front

I've been puzzled by this on my '97 KRS for a few days. Very noticeable freewheeling and definitely wheel speed related. Thought it might be early warning of front wheel bearing failure. Sounds just like a cable speedo about to fail on the cable.

My rotors are floating. I noticed one rotor could be moved side to side to make a similar metallic noise, the other side was firm. I removed the rotor fixing bolts one at a time and re-shaped the stainless compression 'wave washers'. They are there to give friction and stop the rattle.

http://www.realoem.com/bmw/showparts...96&hg=34&fg=05



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!
voxmagna is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome