Turn Signal Troubleshooting - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old Jun 13th, 2007, 4:14 pm Thread Starter
 
Join Date: Oct 2005
Posts: 6
Turn Signal Troubleshooting

I have a K100 thats been sitting without a fuse in the turn signal/clock spot. When I put in a new fuse, the right side signal light on the dash lights up solid, even without the key on. No signals work, bulbs look good, clock works. Any ideas? Thanks.
tweaker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Clear front turn signal and tail light lens kits pebo K12/1300S 24 Apr 20th, 2007 3:47 am
clear front turn signal lenses martys K1200RS/GT (Classic) 11 Apr 14th, 2007 10:56 pm
New mirrors with led turn signal fireman_belgium K12/1300GT (Next Gen) 1 Sep 8th, 2006 8:11 am
turn signal relay milkman K1200RS/GT (Classic) 6 Jan 23rd, 2006 1:41 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome