Lambda sensor failed? - K-Bikes.com - Excellence in Motion
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old May 3rd, 2013, 10:46 am Thread Starter
Noob
 
Join Date: Oct 2012
Location: milton keynes, uk,
Posts: 21
Lambda sensor failed?

Hi all,

i have a weird issue with me 2005 k12r, when moving in gear and clutch in if I rev the engine it sounds gutless and doesn't want to rev freely, but in neautal it's ok, now if if i'm stationary and in gear clutch in and rev it revs fine, the bike doesn't start on a straight away but takes maybe 3secs to fire up, so not sure if it's a coil, lambda sensor or choke at fault?

Any help appreciated.
SUPERSTARDJ01 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old May 6th, 2013, 1:08 pm
Enthusiast
 
volvor's Avatar
 
Join Date: Mar 2009
Location: Ann Arbor, mi, usa
Posts: 399
I'd check fuel pressure first.

We are what we repeatedly do. Excellence, then, is not an act, but a habit. Will Durant

2006 K 1200 R
volvor is offline  
post #3 of 4 (permalink) Old May 7th, 2013, 3:25 am Thread Starter
Noob
 
Join Date: Oct 2012
Location: milton keynes, uk,
Posts: 21
How would I do that? is it possible to do at home?
SUPERSTARDJ01 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old May 7th, 2013, 6:22 am
Enthusiast
 
volvor's Avatar
 
Join Date: Mar 2009
Location: Ann Arbor, mi, usa
Posts: 399
Maybe you can't, i guess you know your capabilities. I'm merely making a recommendation. I don't have a simple answer, The tools and necessary knowledge maybe something you'll have to pay for at a good shop. Good luck with it, i'd love to know what you find out.

We are what we repeatedly do. Excellence, then, is not an act, but a habit. Will Durant

2006 K 1200 R
volvor is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the K-Bikes.com - Excellence in Motion forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Oxygen (Lambda) Sensor for '06-'08 K1200GT Ashalina Accessories 0 Mar 8th, 2013 2:13 pm
Lambda Sensor Removal nigeldav K1200RS/GT (Classic) 1 Apr 3rd, 2011 5:17 pm
Is my lambda sensor kaputt? komatias K1200RS/GT (Classic) 3 Jun 20th, 2010 3:30 am
Lambda 02 Blanking plug needed in the uk D4VE K12/1300R/R-Sport 1 Jul 4th, 2008 9:22 am
Lambda sensor testing Sharkbait K12/1300R/R-Sport 7 Oct 29th, 2007 11:37 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome