BMW K1200, K1300, and K1600 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I bought my K12 in August. I took it out for a nice highway run and found I couldn't set the cruise.

Not having owned a BMW, how difficult is it to trouble shoot a cruise issue? I bought a Clymer manual, so I have all the electrical diagrams.

Thanks.
 

·
Registered
Joined
·
516 Posts
I bought my K12 in August. I took it out for a nice highway run and found I couldn't set the cruise.

Not having owned a BMW, how difficult is it to trouble shoot a cruise issue? I bought a Clymer manual, so I have all the electrical diagrams.

Thanks.
The cruise-control main unit has been very reliable (in general) - most issues are related to many micro-switches (clutch, brakes and throttle ramp). To help troubleshoot the system, they have included a simple/crude diagnostic mode in the system.

See this link on YouTube for a troubleshooting tutorial:
http://youtu.be/2ov3-jdII6A?hd=1

When I did this video in 2011, I was convinced that Video was the best medium to convey all the information I had in mind. HOWEVER, I am well aware that it is not the best way to keep this info available near your toolbox or your shop manual to run the steps in the garage.

To compensate for this, I have attached a text summary (in PDF format) with this message.
 

Attachments

·
Registered
Joined
·
12 Posts
Discussion Starter #3
Thanks much. When I slide the switch I do see a red light under the slider. Is a red light normal or does that indicate an issue?

I'm in the process of sanding down scratches in the faring so I can prime and paint it. Once that's done it goes in for a safety inspection after the crash.

So excited to get out on the road this year.

T100angel.
 

·
Registered
Joined
·
516 Posts
Thanks much. When I slide the switch I do see a red light under the slider. Is a red light normal or does that indicate an issue?

I'm in the process of sanding down scratches in the faring so I can prime and paint it. Once that's done it goes in for a safety inspection after the crash.

So excited to get out on the road this year.

T100angel.
YES , the REd LED light under cruise ON-OFF (slider switch) is normal.
Did you follow the video and printed pages instructions to execute the diagnostic routine ? This should give you a good starting point where to look to solve the issue.

OF COURSE, no one will care about the cruise-control working or not for the safety inspection ;-)
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
I have not yet. I'm working on faring repairs after a minor crash. The cruise, while nice, is not highest priority. Getting faring back on the bike, and a safety check come first. Then I will troubleshoot the cruise.

Thanks!
 
1 - 5 of 5 Posts
Top