BMW K1200, K1300, and K1600 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Hello all,

My 07 k12gt suddenly won't start. I turn the key, the dash lights up and the throttle servos still move. I press the starter button and nothing. No crank, no anything. I ordered a new battery because I feel like this is the most simple start. Is there anything else that could be causing this? Thanks!
 

·
Registered
Joined
·
15 Posts
Oddly enough, this happened to me for the first time ever only last week. Must be sunspots.

I turned off the bike, waited a minute, turned it back on and everything was fine. Same symptoms as you.

My guess is that, during it's initial check, the computer finds something it doesn't like, and shuts down. It does this initial check every time the ignition is turned on. I had been working on the brakes/front wheel, so I guess it might have found something it didn't like with the ABS. I read a fault code (using Motoscan) on the ABS immediately afterwards.

I'd suggest a fault code read is your first port of call.
 

·
Registered
Joined
·
165 Posts
Fault code reading is nowadays ALWAYS the first place to go, guaranteed. If you have to find a code reader, it might be difficult, but get to know the riders in your neighborhood and someone might be able to help. I got a second hand GS-911 the first chance I could. It was expensive and it didn't help when the fuel pressure sensor went bad, but I live in hope that it will be useful if for nothing better than resetting the service interval indicator.
 
1 - 3 of 3 Posts
Top